summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 83e530750..82428b241 100644
--- a/configure.ac
+++ b/configure.ac
@@ -673,6 +673,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
673 [Use tunnel device compatibility to OpenBSD]) 673 [Use tunnel device compatibility to OpenBSD])
674 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 674 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
675 [Prepend the address family to IP tunnel traffic]) 675 [Prepend the address family to IP tunnel traffic])
676 AC_MSG_CHECKING([if we have the Security Authorization Session API])
677 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
678 [SessionCreate(0, 0);],
679 [ac_cv_use_security_session_api="yes"
680 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
681 [platform has the Security Authorization Session API])
682 LIBS="$LIBS -framework Security"
683 AC_MSG_RESULT([yes])],
684 [ac_cv_use_security_session_api="no"
685 AC_MSG_RESULT([no])])
686 AC_MSG_CHECKING([if we have an in-memory credentials cache])
687 AC_TRY_COMPILE(
688 [#include <Kerberos/Kerberos.h>],
689 [cc_context_t c;
690 (void) cc_initialize (&c, 0, NULL, NULL);],
691 [AC_DEFINE([USE_CCAPI], [1],
692 [platform uses an in-memory credentials cache])
693 LIBS="$LIBS -framework Security"
694 AC_MSG_RESULT([yes])
695 if test "x$ac_cv_use_security_session_api" = "xno"; then
696 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
697 fi],
698 [AC_MSG_RESULT([no])]
699 )
676 m4_pattern_allow([AU_IPv]) 700 m4_pattern_allow([AU_IPv])
677 AC_CHECK_DECL([AU_IPv4], [], 701 AC_CHECK_DECL([AU_IPv4], [],
678 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 702 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])