summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 02e8423c0..233d3cfa1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.466 2011/01/17 05:17:09 djm Exp $ 1# $Id: configure.ac,v 1.467 2011/01/17 10:15:30 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.466 $) 18AC_REVISION($Revision: 1.467 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21# local macros 21# local macros
@@ -1378,7 +1378,7 @@ int main(void)
1378 1378
1379AUDIT_MODULE=none 1379AUDIT_MODULE=none
1380AC_ARG_WITH(audit, 1380AC_ARG_WITH(audit,
1381 [ --with-audit=module Enable EXPERIMENTAL audit support (modules=debug,bsm)], 1381 [ --with-audit=module Enable audit support (modules=debug,bsm,linux)],
1382 [ 1382 [
1383 AC_MSG_CHECKING(for supported audit module) 1383 AC_MSG_CHECKING(for supported audit module)
1384 case "$withval" in 1384 case "$withval" in
@@ -1402,10 +1402,18 @@ AC_ARG_WITH(audit,
1402 AC_CHECK_FUNCS(getaudit_addr aug_get_machine) 1402 AC_CHECK_FUNCS(getaudit_addr aug_get_machine)
1403 AC_DEFINE(USE_BSM_AUDIT, 1, [Use BSM audit module]) 1403 AC_DEFINE(USE_BSM_AUDIT, 1, [Use BSM audit module])
1404 ;; 1404 ;;
1405 linux)
1406 AC_MSG_RESULT(linux)
1407 AUDIT_MODULE=linux
1408 dnl Checks for headers, libs and functions
1409 AC_CHECK_HEADERS(libaudit.h)
1410 SSHDLIBS="$SSHDLIBS -laudit"
1411 AC_DEFINE(USE_LINUX_AUDIT, 1, [Use Linux audit module])
1412 ;;
1405 debug) 1413 debug)
1406 AUDIT_MODULE=debug 1414 AUDIT_MODULE=debug
1407 AC_MSG_RESULT(debug) 1415 AC_MSG_RESULT(debug)
1408 AC_DEFINE(SSH_AUDIT_EVENTS, 1, Use audit debugging module) 1416 AC_DEFINE(SSH_AUDIT_EVENTS, 1, [Use audit debugging module])
1409 ;; 1417 ;;
1410 no) 1418 no)
1411 AC_MSG_RESULT(no) 1419 AC_MSG_RESULT(no)