diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index f23784d9b..ad3c4ab0f 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -514,6 +514,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
514 | [Use tunnel device compatibility to OpenBSD]) | 514 | [Use tunnel device compatibility to OpenBSD]) |
515 | AC_DEFINE(SSH_TUN_PREPEND_AF, 1, | 515 | AC_DEFINE(SSH_TUN_PREPEND_AF, 1, |
516 | [Prepend the address family to IP tunnel traffic]) | 516 | [Prepend the address family to IP tunnel traffic]) |
517 | AC_MSG_CHECKING(if we have the Security Authorization Session API) | ||
518 | AC_TRY_COMPILE([#include <Security/AuthSession.h>], | ||
519 | [SessionCreate(0, 0);], | ||
520 | [ac_cv_use_security_session_api="yes" | ||
521 | AC_DEFINE(USE_SECURITY_SESSION_API, 1, | ||
522 | [platform has the Security Authorization Session API]) | ||
523 | LIBS="$LIBS -framework Security" | ||
524 | AC_MSG_RESULT(yes)], | ||
525 | [ac_cv_use_security_session_api="no" | ||
526 | AC_MSG_RESULT(no)]) | ||
527 | AC_MSG_CHECKING(if we have an in-memory credentials cache) | ||
528 | AC_TRY_COMPILE( | ||
529 | [#include <Kerberos/Kerberos.h>], | ||
530 | [cc_context_t c; | ||
531 | (void) cc_initialize (&c, 0, NULL, NULL);], | ||
532 | [AC_DEFINE(USE_CCAPI, 1, | ||
533 | [platform uses an in-memory credentials cache]) | ||
534 | LIBS="$LIBS -framework Security" | ||
535 | AC_MSG_RESULT(yes) | ||
536 | if test "x$ac_cv_use_security_session_api" = "xno"; then | ||
537 | AC_MSG_ERROR(*** Need a security framework to use the credentials cache API ***) | ||
538 | fi], | ||
539 | [AC_MSG_RESULT(no)] | ||
540 | ) | ||
517 | m4_pattern_allow(AU_IPv) | 541 | m4_pattern_allow(AU_IPv) |
518 | AC_CHECK_DECL(AU_IPv4, [], | 542 | AC_CHECK_DECL(AU_IPv4, [], |
519 | AC_DEFINE(AU_IPv4, 0, [System only supports IPv4 audit records]) | 543 | AC_DEFINE(AU_IPv4, 0, [System only supports IPv4 audit records]) |