summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5f5905b36..13e25e98f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,6 +121,22 @@ AC_CHECK_DECL([PR_SET_NO_NEW_PRIVS], [have_linux_no_new_privs=1], , [
121 #include <linux/prctl.h> 121 #include <linux/prctl.h>
122]) 122])
123 123
124ssh1=yes
125AC_ARG_WITH([ssh1],
126 [ --without-ssh1 Disable support for SSH protocol 1],
127 [ if test "x$withval" = "xno" ; then
128 ssh1=no
129 fi
130 ]
131)
132AC_MSG_CHECKING([whether SSH protocol 1 support is enabled])
133if test "x$ssh1" = "xyes" ; then
134 AC_MSG_RESULT([yes])
135 AC_DEFINE_UNQUOTED([WITH_SSH1], [1], [include SSH protocol version 1 support])
136else
137 AC_MSG_RESULT([no])
138fi
139
124use_stack_protector=1 140use_stack_protector=1
125use_toolchain_hardening=1 141use_toolchain_hardening=1
126AC_ARG_WITH([stackprotect], 142AC_ARG_WITH([stackprotect],
@@ -1523,7 +1539,7 @@ AC_ARG_WITH([audit],
1523) 1539)
1524 1540
1525AC_ARG_WITH([pie], 1541AC_ARG_WITH([pie],
1526 [ --with-pie Build Position Independent Executables if possible], [ 1542 [ --with-pie Build Position Independent Executables if possible], [
1527 if test "x$withval" = "xno"; then 1543 if test "x$withval" = "xno"; then
1528 use_pie=no 1544 use_pie=no
1529 fi 1545 fi
@@ -2314,7 +2330,6 @@ AC_RUN_IFELSE(
2314 2330
2315# XXX make --without-openssl work 2331# XXX make --without-openssl work
2316AC_DEFINE_UNQUOTED([WITH_OPENSSL], [1], [use libcrypto for cryptography]) 2332AC_DEFINE_UNQUOTED([WITH_OPENSSL], [1], [use libcrypto for cryptography])
2317AC_DEFINE_UNQUOTED([WITH_SSH1], [1], [include SSH protocol version 1 support])
2318 2333
2319AC_ARG_WITH([openssl-header-check], 2334AC_ARG_WITH([openssl-header-check],
2320 [ --without-openssl-header-check Disable OpenSSL version consistency check], 2335 [ --without-openssl-header-check Disable OpenSSL version consistency check],