diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 19 |
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac index 5cf7d9097..c5f98468f 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,4 +1,4 @@ | |||
1 | # $Id: configure.ac,v 1.154.2.6 2003/09/22 01:58:44 dtucker Exp $ | 1 | # $Id: configure.ac,v 1.154.2.7 2003/09/22 02:09:18 dtucker Exp $ |
2 | 2 | ||
3 | AC_INIT | 3 | AC_INIT |
4 | AC_CONFIG_SRCDIR([ssh.c]) | 4 | AC_CONFIG_SRCDIR([ssh.c]) |
@@ -731,7 +731,7 @@ dnl Checks for library functions. Please keep in alphabetical order | |||
731 | AC_CHECK_FUNCS(\ | 731 | AC_CHECK_FUNCS(\ |
732 | arc4random __b64_ntop b64_ntop __b64_pton b64_pton basename \ | 732 | arc4random __b64_ntop b64_ntop __b64_pton b64_pton basename \ |
733 | bcopy bindresvport_sa clock fchmod fchown freeaddrinfo futimes \ | 733 | bcopy bindresvport_sa clock fchmod fchown freeaddrinfo futimes \ |
734 | gai_strerror getaddrinfo getcwd getgrouplist getnameinfo getopt \ | 734 | getaddrinfo getcwd getgrouplist getnameinfo getopt \ |
735 | getpeereid _getpty getrlimit getttyent glob inet_aton \ | 735 | getpeereid _getpty getrlimit getttyent glob inet_aton \ |
736 | inet_ntoa inet_ntop innetgr login_getcapbool md5_crypt memmove \ | 736 | inet_ntoa inet_ntop innetgr login_getcapbool md5_crypt memmove \ |
737 | mkdtemp mmap ngetaddrinfo nsleep ogetaddrinfo openlog_r openpty \ | 737 | mkdtemp mmap ngetaddrinfo nsleep ogetaddrinfo openlog_r openpty \ |
@@ -743,6 +743,21 @@ AC_CHECK_FUNCS(\ | |||
743 | truncate utimes vhangup vsnprintf waitpid \ | 743 | truncate utimes vhangup vsnprintf waitpid \ |
744 | ) | 744 | ) |
745 | 745 | ||
746 | # IRIX has a const char return value for gai_strerror() | ||
747 | AC_CHECK_FUNCS(gai_strerror,[ | ||
748 | AC_DEFINE(HAVE_GAI_STRERROR) | ||
749 | AC_TRY_COMPILE([ | ||
750 | #include <sys/types.h> | ||
751 | #include <sys/socket.h> | ||
752 | #include <netdb.h> | ||
753 | |||
754 | const char *gai_strerror(int);],[ | ||
755 | char *str; | ||
756 | |||
757 | str = gai_strerror(0);],[ | ||
758 | AC_DEFINE(HAVE_CONST_GAI_STRERROR_PROTO, 1, | ||
759 | [Define if gai_strerror() returns const char *])])]) | ||
760 | |||
746 | AC_SEARCH_LIBS(nanosleep, rt posix4, AC_DEFINE(HAVE_NANOSLEEP)) | 761 | AC_SEARCH_LIBS(nanosleep, rt posix4, AC_DEFINE(HAVE_NANOSLEEP)) |
747 | 762 | ||
748 | dnl Make sure prototypes are defined for these before using them. | 763 | dnl Make sure prototypes are defined for these before using them. |