diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 14 |
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac index 3e0821bae..43732abb8 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,4 +1,4 @@ | |||
1 | # $Id: configure.ac,v 1.410 2008/11/19 05:26:42 tim Exp $ | 1 | # $Id: configure.ac,v 1.411 2008/12/07 22:35:36 djm Exp $ |
2 | # | 2 | # |
3 | # Copyright (c) 1999-2004 Damien Miller | 3 | # Copyright (c) 1999-2004 Damien Miller |
4 | # | 4 | # |
@@ -15,7 +15,7 @@ | |||
15 | # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. | 15 | # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. |
16 | 16 | ||
17 | AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) | 17 | AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) |
18 | AC_REVISION($Revision: 1.410 $) | 18 | AC_REVISION($Revision: 1.411 $) |
19 | AC_CONFIG_SRCDIR([ssh.c]) | 19 | AC_CONFIG_SRCDIR([ssh.c]) |
20 | 20 | ||
21 | AC_CONFIG_HEADER(config.h) | 21 | AC_CONFIG_HEADER(config.h) |
@@ -126,7 +126,7 @@ int main(void){char b[10]; memset(b, 0, sizeof(b));} | |||
126 | 126 | ||
127 | # -fstack-protector-all doesn't always work for some GCC versions | 127 | # -fstack-protector-all doesn't always work for some GCC versions |
128 | # and/or platforms, so we test if we can. If it's not supported | 128 | # and/or platforms, so we test if we can. If it's not supported |
129 | # on a give platform gcc will emit a warning so we use -Werror. | 129 | # on a given platform gcc will emit a warning so we use -Werror. |
130 | if test "x$use_stack_protector" = "x1"; then | 130 | if test "x$use_stack_protector" = "x1"; then |
131 | for t in -fstack-protector-all -fstack-protector; do | 131 | for t in -fstack-protector-all -fstack-protector; do |
132 | AC_MSG_CHECKING(if $CC supports $t) | 132 | AC_MSG_CHECKING(if $CC supports $t) |
@@ -136,8 +136,8 @@ int main(void){char b[10]; memset(b, 0, sizeof(b));} | |||
136 | LDFLAGS="$LDFLAGS $t -Werror" | 136 | LDFLAGS="$LDFLAGS $t -Werror" |
137 | AC_LINK_IFELSE( | 137 | AC_LINK_IFELSE( |
138 | [AC_LANG_SOURCE([ | 138 | [AC_LANG_SOURCE([ |
139 | #include <stdlib.h> | 139 | #include <stdio.h> |
140 | int main(void){return 0;} | 140 | int main(void){char x[[256]]; snprintf(x, sizeof(x), "XXX"); return 0;} |
141 | ])], | 141 | ])], |
142 | [ AC_MSG_RESULT(yes) | 142 | [ AC_MSG_RESULT(yes) |
143 | CFLAGS="$saved_CFLAGS $t" | 143 | CFLAGS="$saved_CFLAGS $t" |
@@ -145,8 +145,8 @@ int main(void){return 0;} | |||
145 | AC_MSG_CHECKING(if $t works) | 145 | AC_MSG_CHECKING(if $t works) |
146 | AC_RUN_IFELSE( | 146 | AC_RUN_IFELSE( |
147 | [AC_LANG_SOURCE([ | 147 | [AC_LANG_SOURCE([ |
148 | #include <stdlib.h> | 148 | #include <stdio.h> |
149 | int main(void){exit(0);} | 149 | int main(void){char x[[256]]; snprintf(x, sizeof(x), "XXX"); return 0;} |
150 | ])], | 150 | ])], |
151 | [ AC_MSG_RESULT(yes) | 151 | [ AC_MSG_RESULT(yes) |
152 | break ], | 152 | break ], |