diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index 7a915272d..58da1f167 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -515,6 +515,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
515 | [Use tunnel device compatibility to OpenBSD]) | 515 | [Use tunnel device compatibility to OpenBSD]) |
516 | AC_DEFINE([SSH_TUN_PREPEND_AF], [1], | 516 | AC_DEFINE([SSH_TUN_PREPEND_AF], [1], |
517 | [Prepend the address family to IP tunnel traffic]) | 517 | [Prepend the address family to IP tunnel traffic]) |
518 | AC_MSG_CHECKING([if we have the Security Authorization Session API]) | ||
519 | AC_TRY_COMPILE([#include <Security/AuthSession.h>], | ||
520 | [SessionCreate(0, 0);], | ||
521 | [ac_cv_use_security_session_api="yes" | ||
522 | AC_DEFINE([USE_SECURITY_SESSION_API], [1], | ||
523 | [platform has the Security Authorization Session API]) | ||
524 | LIBS="$LIBS -framework Security" | ||
525 | AC_MSG_RESULT([yes])], | ||
526 | [ac_cv_use_security_session_api="no" | ||
527 | AC_MSG_RESULT([no])]) | ||
528 | AC_MSG_CHECKING([if we have an in-memory credentials cache]) | ||
529 | AC_TRY_COMPILE( | ||
530 | [#include <Kerberos/Kerberos.h>], | ||
531 | [cc_context_t c; | ||
532 | (void) cc_initialize (&c, 0, NULL, NULL);], | ||
533 | [AC_DEFINE([USE_CCAPI], [1], | ||
534 | [platform uses an in-memory credentials cache]) | ||
535 | LIBS="$LIBS -framework Security" | ||
536 | AC_MSG_RESULT([yes]) | ||
537 | if test "x$ac_cv_use_security_session_api" = "xno"; then | ||
538 | AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***]) | ||
539 | fi], | ||
540 | [AC_MSG_RESULT([no])] | ||
541 | ) | ||
518 | m4_pattern_allow([AU_IPv]) | 542 | m4_pattern_allow([AU_IPv]) |
519 | AC_CHECK_DECL([AU_IPv4], [], | 543 | AC_CHECK_DECL([AU_IPv4], [], |
520 | AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) | 544 | AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) |