diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index fcf7e416b..ba9d9a37a 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -473,6 +473,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
473 | [Use tunnel device compatibility to OpenBSD]) | 473 | [Use tunnel device compatibility to OpenBSD]) |
474 | AC_DEFINE(SSH_TUN_PREPEND_AF, 1, | 474 | AC_DEFINE(SSH_TUN_PREPEND_AF, 1, |
475 | [Prepend the address family to IP tunnel traffic]) | 475 | [Prepend the address family to IP tunnel traffic]) |
476 | AC_MSG_CHECKING(if we have the Security Authorization Session API) | ||
477 | AC_TRY_COMPILE([#include <Security/AuthSession.h>], | ||
478 | [SessionCreate(0, 0);], | ||
479 | [ac_cv_use_security_session_api="yes" | ||
480 | AC_DEFINE(USE_SECURITY_SESSION_API, 1, | ||
481 | [platform has the Security Authorization Session API]) | ||
482 | LIBS="$LIBS -framework Security" | ||
483 | AC_MSG_RESULT(yes)], | ||
484 | [ac_cv_use_security_session_api="no" | ||
485 | AC_MSG_RESULT(no)]) | ||
486 | AC_MSG_CHECKING(if we have an in-memory credentials cache) | ||
487 | AC_TRY_COMPILE( | ||
488 | [#include <Kerberos/Kerberos.h>], | ||
489 | [cc_context_t c; | ||
490 | (void) cc_initialize (&c, 0, NULL, NULL);], | ||
491 | [AC_DEFINE(USE_CCAPI, 1, | ||
492 | [platform uses an in-memory credentials cache]) | ||
493 | LIBS="$LIBS -framework Security" | ||
494 | AC_MSG_RESULT(yes) | ||
495 | if test "x$ac_cv_use_security_session_api" = "xno"; then | ||
496 | AC_MSG_ERROR(*** Need a security framework to use the credentials cache API ***) | ||
497 | fi], | ||
498 | [AC_MSG_RESULT(no)] | ||
499 | ) | ||
476 | m4_pattern_allow(AU_IPv) | 500 | m4_pattern_allow(AU_IPv) |
477 | AC_CHECK_DECL(AU_IPv4, [], | 501 | AC_CHECK_DECL(AU_IPv4, [], |
478 | AC_DEFINE(AU_IPv4, 0, [System only supports IPv4 audit records]) | 502 | AC_DEFINE(AU_IPv4, 0, [System only supports IPv4 audit records]) |