diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index ea9f1bb56..2f1dfbaff 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -477,6 +477,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
477 | [Use tunnel device compatibility to OpenBSD]) | 477 | [Use tunnel device compatibility to OpenBSD]) |
478 | AC_DEFINE(SSH_TUN_PREPEND_AF, 1, | 478 | AC_DEFINE(SSH_TUN_PREPEND_AF, 1, |
479 | [Prepend the address family to IP tunnel traffic]) | 479 | [Prepend the address family to IP tunnel traffic]) |
480 | AC_MSG_CHECKING(if we have the Security Authorization Session API) | ||
481 | AC_TRY_COMPILE([#include <Security/AuthSession.h>], | ||
482 | [SessionCreate(0, 0);], | ||
483 | [ac_cv_use_security_session_api="yes" | ||
484 | AC_DEFINE(USE_SECURITY_SESSION_API, 1, | ||
485 | [platform has the Security Authorization Session API]) | ||
486 | LIBS="$LIBS -framework Security" | ||
487 | AC_MSG_RESULT(yes)], | ||
488 | [ac_cv_use_security_session_api="no" | ||
489 | AC_MSG_RESULT(no)]) | ||
490 | AC_MSG_CHECKING(if we have an in-memory credentials cache) | ||
491 | AC_TRY_COMPILE( | ||
492 | [#include <Kerberos/Kerberos.h>], | ||
493 | [cc_context_t c; | ||
494 | (void) cc_initialize (&c, 0, NULL, NULL);], | ||
495 | [AC_DEFINE(USE_CCAPI, 1, | ||
496 | [platform uses an in-memory credentials cache]) | ||
497 | LIBS="$LIBS -framework Security" | ||
498 | AC_MSG_RESULT(yes) | ||
499 | if test "x$ac_cv_use_security_session_api" = "xno"; then | ||
500 | AC_MSG_ERROR(*** Need a security framework to use the credentials cache API ***) | ||
501 | fi], | ||
502 | [AC_MSG_RESULT(no)] | ||
503 | ) | ||
480 | m4_pattern_allow(AU_IPv) | 504 | m4_pattern_allow(AU_IPv) |
481 | AC_CHECK_DECL(AU_IPv4, [], | 505 | AC_CHECK_DECL(AU_IPv4, [], |
482 | AC_DEFINE(AU_IPv4, 0, [System only supports IPv4 audit records]) | 506 | AC_DEFINE(AU_IPv4, 0, [System only supports IPv4 audit records]) |