diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 57 |
1 files changed, 57 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index ead34acf5..a92425dbc 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1494,6 +1494,62 @@ AC_ARG_WITH([skey], | |||
1494 | ] | 1494 | ] |
1495 | ) | 1495 | ) |
1496 | 1496 | ||
1497 | # Check whether user wants TCP wrappers support | ||
1498 | TCPW_MSG="no" | ||
1499 | AC_ARG_WITH([tcp-wrappers], | ||
1500 | [ --with-tcp-wrappers[[=PATH]] Enable tcpwrappers support (optionally in PATH)], | ||
1501 | [ | ||
1502 | if test "x$withval" != "xno" ; then | ||
1503 | saved_LIBS="$LIBS" | ||
1504 | saved_LDFLAGS="$LDFLAGS" | ||
1505 | saved_CPPFLAGS="$CPPFLAGS" | ||
1506 | if test -n "${withval}" && \ | ||
1507 | test "x${withval}" != "xyes"; then | ||
1508 | if test -d "${withval}/lib"; then | ||
1509 | if test -n "${need_dash_r}"; then | ||
1510 | LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}" | ||
1511 | else | ||
1512 | LDFLAGS="-L${withval}/lib ${LDFLAGS}" | ||
1513 | fi | ||
1514 | else | ||
1515 | if test -n "${need_dash_r}"; then | ||
1516 | LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}" | ||
1517 | else | ||
1518 | LDFLAGS="-L${withval} ${LDFLAGS}" | ||
1519 | fi | ||
1520 | fi | ||
1521 | if test -d "${withval}/include"; then | ||
1522 | CPPFLAGS="-I${withval}/include ${CPPFLAGS}" | ||
1523 | else | ||
1524 | CPPFLAGS="-I${withval} ${CPPFLAGS}" | ||
1525 | fi | ||
1526 | fi | ||
1527 | LIBS="-lwrap $LIBS" | ||
1528 | AC_MSG_CHECKING([for libwrap]) | ||
1529 | AC_LINK_IFELSE([AC_LANG_PROGRAM([[ | ||
1530 | #include <sys/types.h> | ||
1531 | #include <sys/socket.h> | ||
1532 | #include <netinet/in.h> | ||
1533 | #include <tcpd.h> | ||
1534 | int deny_severity = 0, allow_severity = 0; | ||
1535 | ]], [[ | ||
1536 | hosts_access(0); | ||
1537 | ]])], [ | ||
1538 | AC_MSG_RESULT([yes]) | ||
1539 | AC_DEFINE([LIBWRAP], [1], | ||
1540 | [Define if you want | ||
1541 | TCP Wrappers support]) | ||
1542 | SSHDLIBS="$SSHDLIBS -lwrap" | ||
1543 | TCPW_MSG="yes" | ||
1544 | ], [ | ||
1545 | AC_MSG_ERROR([*** libwrap missing]) | ||
1546 | |||
1547 | ]) | ||
1548 | LIBS="$saved_LIBS" | ||
1549 | fi | ||
1550 | ] | ||
1551 | ) | ||
1552 | |||
1497 | # Check whether user wants to use ldns | 1553 | # Check whether user wants to use ldns |
1498 | LDNS_MSG="no" | 1554 | LDNS_MSG="no" |
1499 | AC_ARG_WITH(ldns, | 1555 | AC_ARG_WITH(ldns, |
@@ -5117,6 +5173,7 @@ echo " KerberosV support: $KRB5_MSG" | |||
5117 | echo " SELinux support: $SELINUX_MSG" | 5173 | echo " SELinux support: $SELINUX_MSG" |
5118 | echo " Smartcard support: $SCARD_MSG" | 5174 | echo " Smartcard support: $SCARD_MSG" |
5119 | echo " S/KEY support: $SKEY_MSG" | 5175 | echo " S/KEY support: $SKEY_MSG" |
5176 | echo " TCP Wrappers support: $TCPW_MSG" | ||
5120 | echo " MD5 password support: $MD5_MSG" | 5177 | echo " MD5 password support: $MD5_MSG" |
5121 | echo " libedit support: $LIBEDIT_MSG" | 5178 | echo " libedit support: $LIBEDIT_MSG" |
5122 | echo " libldns support: $LDNS_MSG" | 5179 | echo " libldns support: $LDNS_MSG" |