summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 21 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4413ae343..4d551b897 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.375 2007/03/26 16:35:28 tim Exp $ 1# $Id: configure.ac,v 1.376 2007/04/29 03:58:07 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.375 $) 18AC_REVISION($Revision: 1.376 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -3154,6 +3154,25 @@ int main()
3154 [#include <arpa/nameser.h>]) 3154 [#include <arpa/nameser.h>])
3155 ]) 3155 ])
3156 3156
3157AC_MSG_CHECKING(if struct __res_state _res is an extern)
3158AC_LINK_IFELSE([
3159#include <stdio.h>
3160#if HAVE_SYS_TYPES_H
3161# include <sys/types.h>
3162#endif
3163#include <netinet/in.h>
3164#include <arpa/nameser.h>
3165#include <resolv.h>
3166extern struct __res_state _res;
3167int main() { return 0; }
3168 ],
3169 [AC_MSG_RESULT(yes)
3170 AC_DEFINE(HAVE__RES_EXTERN, 1,
3171 [Define if you have struct __res_state _res as an extern])
3172 ],
3173 [ AC_MSG_RESULT(no) ]
3174)
3175
3157# Check whether user wants SELinux support 3176# Check whether user wants SELinux support
3158SELINUX_MSG="no" 3177SELINUX_MSG="no"
3159LIBSELINUX="" 3178LIBSELINUX=""