diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 27 |
1 files changed, 22 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac index a0b781ee4..ea9f1bb56 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,4 +1,4 @@ | |||
1 | # $Id: configure.ac,v 1.426 2009/09/01 08:26:00 dtucker Exp $ | 1 | # $Id: configure.ac,v 1.427 2009/09/11 04:56:08 dtucker Exp $ |
2 | # | 2 | # |
3 | # Copyright (c) 1999-2004 Damien Miller | 3 | # Copyright (c) 1999-2004 Damien Miller |
4 | # | 4 | # |
@@ -15,7 +15,7 @@ | |||
15 | # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. | 15 | # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. |
16 | 16 | ||
17 | AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) | 17 | AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) |
18 | AC_REVISION($Revision: 1.426 $) | 18 | AC_REVISION($Revision: 1.427 $) |
19 | AC_CONFIG_SRCDIR([ssh.c]) | 19 | AC_CONFIG_SRCDIR([ssh.c]) |
20 | 20 | ||
21 | AC_CONFIG_HEADER(config.h) | 21 | AC_CONFIG_HEADER(config.h) |
@@ -3324,12 +3324,30 @@ AC_SEARCH_LIBS(getrrsetbyname, resolv, | |||
3324 | AC_SEARCH_LIBS(res_query, resolv) | 3324 | AC_SEARCH_LIBS(res_query, resolv) |
3325 | AC_SEARCH_LIBS(dn_expand, resolv) | 3325 | AC_SEARCH_LIBS(dn_expand, resolv) |
3326 | AC_MSG_CHECKING(if res_query will link) | 3326 | AC_MSG_CHECKING(if res_query will link) |
3327 | AC_TRY_LINK_FUNC(res_query, AC_MSG_RESULT(yes), | 3327 | AC_LINK_IFELSE([ |
3328 | #include "confdefs.h" | ||
3329 | #include <sys/types.h> | ||
3330 | #include <netinet/in.h> | ||
3331 | #include <arpa/nameser.h> | ||
3332 | #include <netdb.h> | ||
3333 | #include <resolv.h> | ||
3334 | int main() | ||
3335 | { | ||
3336 | res_query (0, 0, 0, 0, 0); | ||
3337 | return 0; | ||
3338 | } | ||
3339 | ], | ||
3340 | AC_MSG_RESULT(yes), | ||
3328 | [AC_MSG_RESULT(no) | 3341 | [AC_MSG_RESULT(no) |
3329 | saved_LIBS="$LIBS" | 3342 | saved_LIBS="$LIBS" |
3330 | LIBS="$LIBS -lresolv" | 3343 | LIBS="$LIBS -lresolv" |
3331 | AC_MSG_CHECKING(for res_query in -lresolv) | 3344 | AC_MSG_CHECKING(for res_query in -lresolv) |
3332 | AC_LINK_IFELSE([ | 3345 | AC_LINK_IFELSE([ |
3346 | #include "confdefs.h" | ||
3347 | #include <sys/types.h> | ||
3348 | #include <netinet/in.h> | ||
3349 | #include <arpa/nameser.h> | ||
3350 | #include <netdb.h> | ||
3333 | #include <resolv.h> | 3351 | #include <resolv.h> |
3334 | int main() | 3352 | int main() |
3335 | { | 3353 | { |
@@ -3337,8 +3355,7 @@ int main() | |||
3337 | return 0; | 3355 | return 0; |
3338 | } | 3356 | } |
3339 | ], | 3357 | ], |
3340 | [LIBS="$LIBS -lresolv" | 3358 | [AC_MSG_RESULT(yes)], |
3341 | AC_MSG_RESULT(yes)], | ||
3342 | [LIBS="$saved_LIBS" | 3359 | [LIBS="$saved_LIBS" |
3343 | AC_MSG_RESULT(no)]) | 3360 | AC_MSG_RESULT(no)]) |
3344 | ]) | 3361 | ]) |