summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 20 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c4feaf752..eb24fa00e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.330 2006/02/19 11:50:20 dtucker Exp $ 1# $Id: configure.ac,v 1.331 2006/02/20 09:17:36 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.330 $) 18AC_REVISION($Revision: 1.331 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -1834,6 +1834,24 @@ Also see contrib/findssl.sh for help identifying header/library mismatches.])
1834 ] 1834 ]
1835) 1835)
1836 1836
1837AC_ARG_WITH(ssl-engine,
1838 [ --with-ssl-engine Enable OpenSSL (hardware) ENGINE support ],
1839 [ if test "x$withval" != "xno" ; then
1840 AC_MSG_CHECKING(for OpenSSL ENGINE support)
1841 AC_TRY_COMPILE(
1842 [ #include <openssl/engine.h>],
1843 [
1844int main(void){ENGINE_load_builtin_engines();ENGINE_register_all_complete();}
1845 ],
1846 [ AC_MSG_RESULT(yes)
1847 AC_DEFINE(USE_OPENSSL_ENGINE, 1,
1848 [Enable OpenSSL engine support])
1849 ],
1850 [ AC_MSG_ERROR(OpenSSL ENGINE support not found)]
1851 )
1852 fi ]
1853)
1854
1837# Check for OpenSSL without EVP_aes_{192,256}_cbc 1855# Check for OpenSSL without EVP_aes_{192,256}_cbc
1838AC_MSG_CHECKING([whether OpenSSL has crippled AES support]) 1856AC_MSG_CHECKING([whether OpenSSL has crippled AES support])
1839AC_COMPILE_IFELSE( 1857AC_COMPILE_IFELSE(