diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 45 |
1 files changed, 35 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac index e1844eb56..d86a2062d 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,4 +1,4 @@ | |||
1 | # $Id: configure.ac,v 1.4 2001/11/03 19:09:33 tim Exp $ | 1 | # $Id: configure.ac,v 1.5 2001/11/27 01:19:43 tim Exp $ |
2 | 2 | ||
3 | AC_INIT | 3 | AC_INIT |
4 | AC_CONFIG_SRCDIR([ssh.c]) | 4 | AC_CONFIG_SRCDIR([ssh.c]) |
@@ -65,7 +65,7 @@ case "$host" in | |||
65 | AC_DEFINE(DISABLE_LASTLOG) | 65 | AC_DEFINE(DISABLE_LASTLOG) |
66 | ;; | 66 | ;; |
67 | *-*-cygwin*) | 67 | *-*-cygwin*) |
68 | LIBS="$LIBS -lregex /usr/lib/textmode.o" | 68 | LIBS="$LIBS /usr/lib/textmode.o" |
69 | AC_DEFINE(HAVE_CYGWIN) | 69 | AC_DEFINE(HAVE_CYGWIN) |
70 | AC_DEFINE(USE_PIPES) | 70 | AC_DEFINE(USE_PIPES) |
71 | AC_DEFINE(DISABLE_SHADOW) | 71 | AC_DEFINE(DISABLE_SHADOW) |
@@ -401,18 +401,43 @@ AC_CHECK_LIB(z, deflate, ,AC_MSG_ERROR([*** zlib missing - please install first | |||
401 | # We don't want to check if we did an pcre override. | 401 | # We don't want to check if we did an pcre override. |
402 | if test -z "$no_comp_check" ; then | 402 | if test -z "$no_comp_check" ; then |
403 | AC_CHECK_FUNC(regcomp, | 403 | AC_CHECK_FUNC(regcomp, |
404 | [ AC_DEFINE(HAVE_REGCOMP)], | ||
405 | [ | 404 | [ |
406 | AC_CHECK_LIB(pcre, pcre_info, | 405 | AC_CHECK_FUNC(regsub, |
406 | [ | ||
407 | has_regcomp=no | ||
408 | ], | ||
409 | [ | ||
410 | AC_DEFINE(HAVE_REGCOMP) | ||
411 | has_regcomp=yes | ||
412 | ] | ||
413 | ) | ||
414 | ], | ||
415 | [ | ||
416 | has_regcomp=no | ||
417 | ] | ||
418 | ) | ||
419 | # Either regcomp wasn't defined or regsub is defined (which means | ||
420 | # that the libc regex is probably an old non-POSIX implementation. | ||
421 | # Now check for -lregex and -lpcreposix to find some usable regex | ||
422 | # implementation. | ||
423 | if test "$has_regcomp" = "no" ; then | ||
424 | AC_CHECK_LIB(regex, regcomp, | ||
407 | [ | 425 | [ |
408 | AC_DEFINE(HAVE_LIBPCRE) | 426 | AC_DEFINE(HAVE_REGCOMP) |
409 | LIBS="$LIBS -lpcreposix -lpcre" | 427 | LIBS="$LIBS -lregex" |
410 | ], | 428 | ], |
411 | [ | 429 | [ |
412 | AC_MSG_ERROR([*** No regex library found.]) | 430 | AC_CHECK_LIB(pcre, pcre_info, |
413 | ]) | 431 | [ |
414 | ] | 432 | AC_DEFINE(HAVE_LIBPCRE) |
415 | ) | 433 | LIBS="$LIBS -lpcreposix -lpcre" |
434 | ], | ||
435 | [ | ||
436 | AC_MSG_ERROR([*** No regex library found.]) | ||
437 | ]) | ||
438 | ] | ||
439 | ) | ||
440 | fi | ||
416 | fi | 441 | fi |
417 | 442 | ||
418 | dnl UnixWare 2.x | 443 | dnl UnixWare 2.x |