summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 27 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4d55c46fc..128889a28 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,7 +122,7 @@ AC_CHECK_DECL([PR_SET_NO_NEW_PRIVS], [have_linux_no_new_privs=1], , [
122]) 122])
123 123
124openssl=yes 124openssl=yes
125ssh1=yes 125ssh1=no
126AC_ARG_WITH([openssl], 126AC_ARG_WITH([openssl],
127 [ --without-openssl Disable use of OpenSSL; use only limited internal crypto **EXPERIMENTAL** ], 127 [ --without-openssl Disable use of OpenSSL; use only limited internal crypto **EXPERIMENTAL** ],
128 [ if test "x$withval" = "xno" ; then 128 [ if test "x$withval" = "xno" ; then
@@ -1754,7 +1754,6 @@ AC_CHECK_FUNCS([ \
1754 pstat \ 1754 pstat \
1755 readpassphrase \ 1755 readpassphrase \
1756 reallocarray \ 1756 reallocarray \
1757 realpath \
1758 recvmsg \ 1757 recvmsg \
1759 rresvport_af \ 1758 rresvport_af \
1760 sendmsg \ 1759 sendmsg \
@@ -1971,6 +1970,32 @@ AC_CHECK_FUNCS([setresgid], [
1971 ) 1970 )
1972]) 1971])
1973 1972
1973AC_CHECK_FUNCS([realpath], [
1974 dnl the sftp v3 spec says SSH_FXP_REALPATH will "canonicalize any given
1975 dnl path name", however some implementations of realpath (and some
1976 dnl versions of the POSIX spec) do not work on non-existent files,
1977 dnl so we use the OpenBSD implementation on those platforms.
1978 AC_MSG_CHECKING([if realpath works with non-existent files])
1979 AC_RUN_IFELSE(
1980 [AC_LANG_PROGRAM([[
1981#include <limits.h>
1982#include <stdlib.h>
1983#include <errno.h>
1984 ]], [[
1985 char buf[PATH_MAX];
1986 if (realpath("/opensshnonexistentfilename1234", buf) == NULL)
1987 if (errno == ENOENT)
1988 exit(1);
1989 exit(0);
1990 ]])],
1991 [AC_MSG_RESULT([yes])],
1992 [AC_DEFINE([BROKEN_REALPATH], [1],
1993 [realpath does not work with nonexistent files])
1994 AC_MSG_RESULT([no])],
1995 [AC_MSG_WARN([cross compiling: assuming working])]
1996 )
1997])
1998
1974dnl Checks for time functions 1999dnl Checks for time functions
1975AC_CHECK_FUNCS([gettimeofday time]) 2000AC_CHECK_FUNCS([gettimeofday time])
1976dnl Checks for utmp functions 2001dnl Checks for utmp functions