diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 42 |
1 files changed, 39 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac index fcf7e416b..991e0fef3 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -478,6 +478,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
478 | AC_DEFINE(AU_IPv4, 0, [System only supports IPv4 audit records]) | 478 | AC_DEFINE(AU_IPv4, 0, [System only supports IPv4 audit records]) |
479 | [#include <bsm/audit.h>] | 479 | [#include <bsm/audit.h>] |
480 | ) | 480 | ) |
481 | AC_MSG_CHECKING(if we have the Security Authorization Session API) | ||
482 | AC_TRY_COMPILE([#include <Security/AuthSession.h>], | ||
483 | [SessionCreate(0, 0);], | ||
484 | [ac_cv_use_security_session_api="yes" | ||
485 | AC_DEFINE(USE_SECURITY_SESSION_API, 1, | ||
486 | [platform has the Security Authorization Session API]) | ||
487 | LIBS="$LIBS -framework Security" | ||
488 | AC_MSG_RESULT(yes)], | ||
489 | [ac_cv_use_security_session_api="no" | ||
490 | AC_MSG_RESULT(no)]) | ||
491 | AC_MSG_CHECKING(if we have an in-memory credentials cache) | ||
492 | AC_TRY_COMPILE( | ||
493 | [#include <Kerberos/Kerberos.h>], | ||
494 | [cc_context_t c; | ||
495 | (void) cc_initialize (&c, 0, NULL, NULL);], | ||
496 | [AC_DEFINE(USE_CCAPI, 1, | ||
497 | [platform uses an in-memory credentials cache]) | ||
498 | LIBS="$LIBS -framework Security" | ||
499 | AC_MSG_RESULT(yes) | ||
500 | if test "x$ac_cv_use_security_session_api" = "xno"; then | ||
501 | AC_MSG_ERROR(*** Need a security framework to use the credentials cache API ***) | ||
502 | fi], | ||
503 | [AC_MSG_RESULT(no)] | ||
504 | ) | ||
481 | ;; | 505 | ;; |
482 | *-*-dragonfly*) | 506 | *-*-dragonfly*) |
483 | SSHDLIBS="$SSHDLIBS -lcrypt" | 507 | SSHDLIBS="$SSHDLIBS -lcrypt" |
@@ -561,6 +585,14 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
561 | AC_DEFINE(WITH_ABBREV_NO_TTY) | 585 | AC_DEFINE(WITH_ABBREV_NO_TTY) |
562 | AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*") | 586 | AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*") |
563 | ;; | 587 | ;; |
588 | *-*-k*bsd*-gnu) | ||
589 | check_for_libcrypt_later=1 | ||
590 | AC_DEFINE(PAM_TTY_KLUDGE) | ||
591 | AC_DEFINE(LOCKED_PASSWD_PREFIX, "!") | ||
592 | AC_DEFINE(SPT_TYPE,SPT_REUSEARGV) | ||
593 | AC_DEFINE(_PATH_BTMP, "/var/log/btmp", [log for bad login attempts]) | ||
594 | AC_DEFINE(USE_BTMP, 1, [Use btmp to log bad logins]) | ||
595 | ;; | ||
564 | *-*-linux*) | 596 | *-*-linux*) |
565 | no_dev_ptmx=1 | 597 | no_dev_ptmx=1 |
566 | check_for_libcrypt_later=1 | 598 | check_for_libcrypt_later=1 |
@@ -592,6 +624,7 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
592 | AC_DEFINE(SSH_TUN_PREPEND_AF, 1, | 624 | AC_DEFINE(SSH_TUN_PREPEND_AF, 1, |
593 | [Prepend the address family to IP tunnel traffic]) | 625 | [Prepend the address family to IP tunnel traffic]) |
594 | fi | 626 | fi |
627 | AC_DEFINE(OOM_ADJUST, 1, [Adjust Linux out-of-memory killer]) | ||
595 | ;; | 628 | ;; |
596 | mips-sony-bsd|mips-sony-newsos4) | 629 | mips-sony-bsd|mips-sony-newsos4) |
597 | AC_DEFINE(NEED_SETPGRP, 1, [Need setpgrp to acquire controlling tty]) | 630 | AC_DEFINE(NEED_SETPGRP, 1, [Need setpgrp to acquire controlling tty]) |
@@ -3305,9 +3338,12 @@ AC_ARG_WITH(selinux, | |||
3305 | AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.]) | 3338 | AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.]) |
3306 | SELINUX_MSG="yes" | 3339 | SELINUX_MSG="yes" |
3307 | AC_CHECK_HEADER([selinux/selinux.h], , | 3340 | AC_CHECK_HEADER([selinux/selinux.h], , |
3308 | AC_MSG_ERROR(SELinux support requires selinux.h header)) | 3341 | AC_MSG_ERROR(SELinux support requires selinux.h header)) |
3309 | AC_CHECK_LIB(selinux, setexeccon, [ LIBSELINUX="-lselinux" ], | 3342 | AC_CHECK_LIB(selinux, setexeccon, |
3310 | AC_MSG_ERROR(SELinux support requires libselinux library)) | 3343 | [ LIBSELINUX="-lselinux" |
3344 | LIBS="$LIBS -lselinux" | ||
3345 | ], | ||
3346 | AC_MSG_ERROR(SELinux support requires libselinux library)) | ||
3311 | SSHDLIBS="$SSHDLIBS $LIBSELINUX" | 3347 | SSHDLIBS="$SSHDLIBS $LIBSELINUX" |
3312 | AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level) | 3348 | AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level) |
3313 | LIBS="$save_LIBS" | 3349 | LIBS="$save_LIBS" |