diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 26 |
1 files changed, 25 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac index a2b236355..18c7ca896 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -403,7 +403,31 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
403 | [Use tunnel device compatibility to OpenBSD]) | 403 | [Use tunnel device compatibility to OpenBSD]) |
404 | AC_DEFINE(SSH_TUN_PREPEND_AF, 1, | 404 | AC_DEFINE(SSH_TUN_PREPEND_AF, 1, |
405 | [Prepend the address family to IP tunnel traffic]) | 405 | [Prepend the address family to IP tunnel traffic]) |
406 | ;; | 406 | AC_MSG_CHECKING(if we have the Security Authorization Session API) |
407 | AC_TRY_COMPILE([#include <Security/AuthSession.h>], | ||
408 | [SessionCreate(0, 0);], | ||
409 | [ac_cv_use_security_session_api="yes" | ||
410 | AC_DEFINE(USE_SECURITY_SESSION_API, 1, | ||
411 | [platform has the Security Authorization Session API]) | ||
412 | LIBS="$LIBS -framework Security" | ||
413 | AC_MSG_RESULT(yes)], | ||
414 | [ac_cv_use_security_session_api="no" | ||
415 | AC_MSG_RESULT(no)]) | ||
416 | AC_MSG_CHECKING(if we have an in-memory credentials cache) | ||
417 | AC_TRY_COMPILE( | ||
418 | [#include <Kerberos/Kerberos.h>], | ||
419 | [cc_context_t c; | ||
420 | (void) cc_initialize (&c, 0, NULL, NULL);], | ||
421 | [AC_DEFINE(USE_CCAPI, 1, | ||
422 | [platform uses an in-memory credentials cache]) | ||
423 | LIBS="$LIBS -framework Security" | ||
424 | AC_MSG_RESULT(yes) | ||
425 | if test "x$ac_cv_use_security_session_api" = "xno"; then | ||
426 | AC_MSG_ERROR(*** Need a security framework to use the credentials cache API ***) | ||
427 | fi], | ||
428 | [AC_MSG_RESULT(no)] | ||
429 | ) | ||
430 | ;; | ||
407 | *-*-dragonfly*) | 431 | *-*-dragonfly*) |
408 | SSHDLIBS="$SSHDLIBS -lcrypt" | 432 | SSHDLIBS="$SSHDLIBS -lcrypt" |
409 | ;; | 433 | ;; |