summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 26ed218d5..2f5906667 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.319 2005/12/31 06:05:58 djm Exp $ 1# $Id: configure.ac,v 1.320 2006/01/01 08:47:05 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -346,10 +346,18 @@ mips-sony-bsd|mips-sony-newsos4)
346 if test "x$withval" != "xno" ; then 346 if test "x$withval" != "xno" ; then
347 need_dash_r=1 347 need_dash_r=1
348 fi 348 fi
349 AC_DEFINE(SSH_TUN_FREEBSD, 1, [Open tunnel devices the FreeBSD way])
350 AC_CHECK_HEADER([net/if_tap.h], ,
351 AC_DEFINE(SSH_TUN_NO_L2, 1, [No layer 2 tunnel support]))
352 AC_DEFINE(SSH_TUN_PREPEND_AF, 1,
353 [Prepend the address family to IP tunnel traffic])
349 ;; 354 ;;
350*-*-freebsd*) 355*-*-freebsd*)
351 check_for_libcrypt_later=1 356 check_for_libcrypt_later=1
352 AC_DEFINE(LOCKED_PASSWD_PREFIX, "*LOCKED*", [Account locked with pw(1)]) 357 AC_DEFINE(LOCKED_PASSWD_PREFIX, "*LOCKED*", [Account locked with pw(1)])
358 AC_DEFINE(SSH_TUN_FREEBSD, 1, [Open tunnel devices the FreeBSD way])
359 AC_CHECK_HEADER([net/if_tap.h], ,
360 AC_DEFINE(SSH_TUN_NO_L2, 1, [No layer 2 tunnel support]))
353 ;; 361 ;;
354*-*-bsdi*) 362*-*-bsdi*)
355 AC_DEFINE(SETEUID_BREAKS_SETUID) 363 AC_DEFINE(SETEUID_BREAKS_SETUID)
@@ -369,7 +377,7 @@ mips-sony-bsd|mips-sony-newsos4)
369*-*-openbsd*) 377*-*-openbsd*)
370 AC_DEFINE(HAVE_ATTRIBUTE__SENTINEL__, 1, [OpenBSD's gcc has sentinel]) 378 AC_DEFINE(HAVE_ATTRIBUTE__SENTINEL__, 1, [OpenBSD's gcc has sentinel])
371 AC_DEFINE(HAVE_ATTRIBUTE__BOUNDED__, 1, [OpenBSD's gcc has bounded]) 379 AC_DEFINE(HAVE_ATTRIBUTE__BOUNDED__, 1, [OpenBSD's gcc has bounded])
372 AC_DEFINE(SSH_TUN_BSD, 1, [Open tunnel devices the BSD way]) 380 AC_DEFINE(SSH_TUN_OPENBSD, 1, [Open tunnel devices the OpenBSD way])
373 ;; 381 ;;
374*-*-solaris*) 382*-*-solaris*)
375 if test "x$withval" != "xno" ; then 383 if test "x$withval" != "xno" ; then