summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ff1972ed6..9ff199451 100644
--- a/configure.ac
+++ b/configure.ac
@@ -311,6 +311,14 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
311 AC_DEFINE(WITH_ABBREV_NO_TTY) 311 AC_DEFINE(WITH_ABBREV_NO_TTY)
312 AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*") 312 AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*")
313 ;; 313 ;;
314*-*-k*bsd*-gnu)
315 check_for_libcrypt_later=1
316 AC_DEFINE(PAM_TTY_KLUDGE)
317 AC_DEFINE(LOCKED_PASSWD_PREFIX, "!")
318 AC_DEFINE(SPT_TYPE,SPT_REUSEARGV)
319 AC_DEFINE(_PATH_BTMP, "/var/log/btmp", [log for bad login attempts])
320 AC_DEFINE(USE_BTMP, 1, [Use btmp to log bad logins])
321 ;;
314*-*-linux*) 322*-*-linux*)
315 no_dev_ptmx=1 323 no_dev_ptmx=1
316 check_for_libcrypt_later=1 324 check_for_libcrypt_later=1
@@ -2952,6 +2960,18 @@ int main()
2952 [#include <arpa/nameser.h>]) 2960 [#include <arpa/nameser.h>])
2953 ]) 2961 ])
2954 2962
2963# Check whether user wants SELinux support
2964SELINUX_MSG="no"
2965AC_ARG_WITH(selinux,
2966 [ --with-selinux Enable SELinux support],
2967 [ if test "x$withval" != "xno" ; then
2968 AC_DEFINE(WITH_SELINUX, 1, [Define if you want SELinux support.])
2969 SELINUX_MSG="yes"
2970 AC_CHECK_HEADERS(selinux/selinux.h)
2971 LIBS="$LIBS -lselinux"
2972 fi
2973 ])
2974
2955# Check whether user wants Kerberos 5 support 2975# Check whether user wants Kerberos 5 support
2956KRB5_MSG="no" 2976KRB5_MSG="no"
2957AC_ARG_WITH(kerberos5, 2977AC_ARG_WITH(kerberos5,
@@ -3770,6 +3790,7 @@ fi
3770echo " Manpage format: $MANTYPE" 3790echo " Manpage format: $MANTYPE"
3771echo " PAM support: $PAM_MSG" 3791echo " PAM support: $PAM_MSG"
3772echo " KerberosV support: $KRB5_MSG" 3792echo " KerberosV support: $KRB5_MSG"
3793echo " SELinux support: $SELINUX_MSG"
3773echo " Smartcard support: $SCARD_MSG" 3794echo " Smartcard support: $SCARD_MSG"
3774echo " S/KEY support: $SKEY_MSG" 3795echo " S/KEY support: $SKEY_MSG"
3775echo " TCP Wrappers support: $TCPW_MSG" 3796echo " TCP Wrappers support: $TCPW_MSG"