diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index 9b05c30f8..7a256034d 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -625,6 +625,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
625 | [Use tunnel device compatibility to OpenBSD]) | 625 | [Use tunnel device compatibility to OpenBSD]) |
626 | AC_DEFINE([SSH_TUN_PREPEND_AF], [1], | 626 | AC_DEFINE([SSH_TUN_PREPEND_AF], [1], |
627 | [Prepend the address family to IP tunnel traffic]) | 627 | [Prepend the address family to IP tunnel traffic]) |
628 | AC_MSG_CHECKING([if we have the Security Authorization Session API]) | ||
629 | AC_TRY_COMPILE([#include <Security/AuthSession.h>], | ||
630 | [SessionCreate(0, 0);], | ||
631 | [ac_cv_use_security_session_api="yes" | ||
632 | AC_DEFINE([USE_SECURITY_SESSION_API], [1], | ||
633 | [platform has the Security Authorization Session API]) | ||
634 | LIBS="$LIBS -framework Security" | ||
635 | AC_MSG_RESULT([yes])], | ||
636 | [ac_cv_use_security_session_api="no" | ||
637 | AC_MSG_RESULT([no])]) | ||
638 | AC_MSG_CHECKING([if we have an in-memory credentials cache]) | ||
639 | AC_TRY_COMPILE( | ||
640 | [#include <Kerberos/Kerberos.h>], | ||
641 | [cc_context_t c; | ||
642 | (void) cc_initialize (&c, 0, NULL, NULL);], | ||
643 | [AC_DEFINE([USE_CCAPI], [1], | ||
644 | [platform uses an in-memory credentials cache]) | ||
645 | LIBS="$LIBS -framework Security" | ||
646 | AC_MSG_RESULT([yes]) | ||
647 | if test "x$ac_cv_use_security_session_api" = "xno"; then | ||
648 | AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***]) | ||
649 | fi], | ||
650 | [AC_MSG_RESULT([no])] | ||
651 | ) | ||
628 | m4_pattern_allow([AU_IPv]) | 652 | m4_pattern_allow([AU_IPv]) |
629 | AC_CHECK_DECL([AU_IPv4], [], | 653 | AC_CHECK_DECL([AU_IPv4], [], |
630 | AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) | 654 | AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) |