summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1e4df2e33..849e2f771 100644
--- a/configure.ac
+++ b/configure.ac
@@ -328,6 +328,14 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
328 AC_DEFINE(WITH_ABBREV_NO_TTY) 328 AC_DEFINE(WITH_ABBREV_NO_TTY)
329 AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*") 329 AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*")
330 ;; 330 ;;
331*-*-k*bsd*-gnu)
332 check_for_libcrypt_later=1
333 AC_DEFINE(PAM_TTY_KLUDGE)
334 AC_DEFINE(LOCKED_PASSWD_PREFIX, "!")
335 AC_DEFINE(SPT_TYPE,SPT_REUSEARGV)
336 AC_DEFINE(_PATH_BTMP, "/var/log/btmp", [log for bad login attempts])
337 AC_DEFINE(USE_BTMP, 1, [Use btmp to log bad logins])
338 ;;
331*-*-linux*) 339*-*-linux*)
332 no_dev_ptmx=1 340 no_dev_ptmx=1
333 check_for_libcrypt_later=1 341 check_for_libcrypt_later=1
@@ -2667,6 +2675,18 @@ int main()
2667 [#include <arpa/nameser.h>]) 2675 [#include <arpa/nameser.h>])
2668 ]) 2676 ])
2669 2677
2678# Check whether user wants SELinux support
2679SELINUX_MSG="no"
2680AC_ARG_WITH(selinux,
2681 [ --with-selinux Enable SELinux support],
2682 [ if test "x$withval" != "xno" ; then
2683 AC_DEFINE(WITH_SELINUX, 1, [Define if you want SELinux support.])
2684 SELINUX_MSG="yes"
2685 AC_CHECK_HEADERS(selinux/selinux.h)
2686 LIBS="$LIBS -lselinux"
2687 fi
2688 ])
2689
2670# Check whether user wants Kerberos 5 support 2690# Check whether user wants Kerberos 5 support
2671KRB5_MSG="no" 2691KRB5_MSG="no"
2672AC_ARG_WITH(kerberos5, 2692AC_ARG_WITH(kerberos5,
@@ -3451,6 +3471,7 @@ fi
3451echo " Manpage format: $MANTYPE" 3471echo " Manpage format: $MANTYPE"
3452echo " PAM support: $PAM_MSG" 3472echo " PAM support: $PAM_MSG"
3453echo " KerberosV support: $KRB5_MSG" 3473echo " KerberosV support: $KRB5_MSG"
3474echo " SELinux support: $SELINUX_MSG"
3454echo " Smartcard support: $SCARD_MSG" 3475echo " Smartcard support: $SCARD_MSG"
3455echo " S/KEY support: $SKEY_MSG" 3476echo " S/KEY support: $SKEY_MSG"
3456echo " TCP Wrappers support: $TCPW_MSG" 3477echo " TCP Wrappers support: $TCPW_MSG"