summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3e93c0276..1c2512314 100644
--- a/configure.ac
+++ b/configure.ac
@@ -666,6 +666,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
666 [Use tunnel device compatibility to OpenBSD]) 666 [Use tunnel device compatibility to OpenBSD])
667 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 667 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
668 [Prepend the address family to IP tunnel traffic]) 668 [Prepend the address family to IP tunnel traffic])
669 AC_MSG_CHECKING([if we have the Security Authorization Session API])
670 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
671 [SessionCreate(0, 0);],
672 [ac_cv_use_security_session_api="yes"
673 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
674 [platform has the Security Authorization Session API])
675 LIBS="$LIBS -framework Security"
676 AC_MSG_RESULT([yes])],
677 [ac_cv_use_security_session_api="no"
678 AC_MSG_RESULT([no])])
679 AC_MSG_CHECKING([if we have an in-memory credentials cache])
680 AC_TRY_COMPILE(
681 [#include <Kerberos/Kerberos.h>],
682 [cc_context_t c;
683 (void) cc_initialize (&c, 0, NULL, NULL);],
684 [AC_DEFINE([USE_CCAPI], [1],
685 [platform uses an in-memory credentials cache])
686 LIBS="$LIBS -framework Security"
687 AC_MSG_RESULT([yes])
688 if test "x$ac_cv_use_security_session_api" = "xno"; then
689 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
690 fi],
691 [AC_MSG_RESULT([no])]
692 )
669 m4_pattern_allow([AU_IPv]) 693 m4_pattern_allow([AU_IPv])
670 AC_CHECK_DECL([AU_IPv4], [], 694 AC_CHECK_DECL([AU_IPv4], [],
671 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 695 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])