diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index 663062bef..1cd5eab6c 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -664,6 +664,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
664 | [Use tunnel device compatibility to OpenBSD]) | 664 | [Use tunnel device compatibility to OpenBSD]) |
665 | AC_DEFINE([SSH_TUN_PREPEND_AF], [1], | 665 | AC_DEFINE([SSH_TUN_PREPEND_AF], [1], |
666 | [Prepend the address family to IP tunnel traffic]) | 666 | [Prepend the address family to IP tunnel traffic]) |
667 | AC_MSG_CHECKING([if we have the Security Authorization Session API]) | ||
668 | AC_TRY_COMPILE([#include <Security/AuthSession.h>], | ||
669 | [SessionCreate(0, 0);], | ||
670 | [ac_cv_use_security_session_api="yes" | ||
671 | AC_DEFINE([USE_SECURITY_SESSION_API], [1], | ||
672 | [platform has the Security Authorization Session API]) | ||
673 | LIBS="$LIBS -framework Security" | ||
674 | AC_MSG_RESULT([yes])], | ||
675 | [ac_cv_use_security_session_api="no" | ||
676 | AC_MSG_RESULT([no])]) | ||
677 | AC_MSG_CHECKING([if we have an in-memory credentials cache]) | ||
678 | AC_TRY_COMPILE( | ||
679 | [#include <Kerberos/Kerberos.h>], | ||
680 | [cc_context_t c; | ||
681 | (void) cc_initialize (&c, 0, NULL, NULL);], | ||
682 | [AC_DEFINE([USE_CCAPI], [1], | ||
683 | [platform uses an in-memory credentials cache]) | ||
684 | LIBS="$LIBS -framework Security" | ||
685 | AC_MSG_RESULT([yes]) | ||
686 | if test "x$ac_cv_use_security_session_api" = "xno"; then | ||
687 | AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***]) | ||
688 | fi], | ||
689 | [AC_MSG_RESULT([no])] | ||
690 | ) | ||
667 | m4_pattern_allow([AU_IPv]) | 691 | m4_pattern_allow([AU_IPv]) |
668 | AC_CHECK_DECL([AU_IPv4], [], | 692 | AC_CHECK_DECL([AU_IPv4], [], |
669 | AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) | 693 | AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) |