summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 3 insertions, 39 deletions
diff --git a/configure.ac b/configure.ac
index 916dc1075..7ddcb777f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.154.2.11 2003/09/23 09:24:21 djm Exp $ 1# $Id: configure.ac,v 1.154.2.1 2003/09/16 05:48:15 tim Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -132,9 +132,6 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
132 [AC_MSG_RESULT(buggy) 132 [AC_MSG_RESULT(buggy)
133 AC_DEFINE(BROKEN_GETADDRINFO)], 133 AC_DEFINE(BROKEN_GETADDRINFO)],
134 [AC_MSG_RESULT(assume it is working)]) 134 [AC_MSG_RESULT(assume it is working)])
135 AC_DEFINE(SETEUID_BREAKS_SETUID)
136 AC_DEFINE(BROKEN_SETREUID)
137 AC_DEFINE(BROKEN_SETREGID)
138 ;; 135 ;;
139*-*-hpux10.26) 136*-*-hpux10.26)
140 if test -z "$GCC"; then 137 if test -z "$GCC"; then
@@ -201,9 +198,6 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
201 AC_DEFINE(WITH_IRIX_AUDIT) 198 AC_DEFINE(WITH_IRIX_AUDIT)
202 AC_CHECK_FUNC(jlimit_startjob, [AC_DEFINE(WITH_IRIX_JOBS)]) 199 AC_CHECK_FUNC(jlimit_startjob, [AC_DEFINE(WITH_IRIX_JOBS)])
203 AC_DEFINE(BROKEN_INET_NTOA) 200 AC_DEFINE(BROKEN_INET_NTOA)
204 AC_DEFINE(SETEUID_BREAKS_SETUID)
205 AC_DEFINE(BROKEN_SETREUID)
206 AC_DEFINE(BROKEN_SETREGID)
207 AC_DEFINE(WITH_ABBREV_NO_TTY) 201 AC_DEFINE(WITH_ABBREV_NO_TTY)
208 AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*") 202 AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*")
209 ;; 203 ;;
@@ -233,11 +227,6 @@ mips-sony-bsd|mips-sony-newsos4)
233*-*-freebsd*) 227*-*-freebsd*)
234 check_for_libcrypt_later=1 228 check_for_libcrypt_later=1
235 ;; 229 ;;
236*-*-bsdi*)
237 AC_DEFINE(SETEUID_BREAKS_SETUID)
238 AC_DEFINE(BROKEN_SETREUID)
239 AC_DEFINE(BROKEN_SETREGID)
240 ;;
241*-next-*) 230*-next-*)
242 conf_lastlog_location="/usr/adm/lastlog" 231 conf_lastlog_location="/usr/adm/lastlog"
243 conf_utmp_location=/etc/utmp 232 conf_utmp_location=/etc/utmp
@@ -289,9 +278,6 @@ mips-sony-bsd|mips-sony-newsos4)
289 LIBS="$LIBS -lc89" 278 LIBS="$LIBS -lc89"
290 AC_DEFINE(USE_PIPES) 279 AC_DEFINE(USE_PIPES)
291 AC_DEFINE(SSHD_ACQUIRES_CTTY) 280 AC_DEFINE(SSHD_ACQUIRES_CTTY)
292 AC_DEFINE(SETEUID_BREAKS_SETUID)
293 AC_DEFINE(BROKEN_SETREUID)
294 AC_DEFINE(BROKEN_SETREGID)
295 ;; 281 ;;
296*-sni-sysv*) 282*-sni-sysv*)
297 CPPFLAGS="$CPPFLAGS -I/usr/local/include" 283 CPPFLAGS="$CPPFLAGS -I/usr/local/include"
@@ -409,9 +395,6 @@ mips-sony-bsd|mips-sony-newsos4)
409 fi 395 fi
410 AC_DEFINE(DISABLE_FD_PASSING) 396 AC_DEFINE(DISABLE_FD_PASSING)
411 AC_DEFINE(BROKEN_GETADDRINFO) 397 AC_DEFINE(BROKEN_GETADDRINFO)
412 AC_DEFINE(SETEUID_BREAKS_SETUID)
413 AC_DEFINE(BROKEN_SETREUID)
414 AC_DEFINE(BROKEN_SETREGID)
415 AC_DEFINE(LOCKED_PASSWD_SUBSTR, "Nologin") 398 AC_DEFINE(LOCKED_PASSWD_SUBSTR, "Nologin")
416 ;; 399 ;;
417 400
@@ -480,7 +463,7 @@ AC_CHECK_HEADERS(bstring.h crypt.h endian.h features.h floatingpoint.h \
480 sys/cdefs.h sys/mman.h sys/pstat.h sys/select.h sys/stat.h \ 463 sys/cdefs.h sys/mman.h sys/pstat.h sys/select.h sys/stat.h \
481 sys/stropts.h sys/sysmacros.h sys/time.h sys/timers.h \ 464 sys/stropts.h sys/sysmacros.h sys/time.h sys/timers.h \
482 sys/un.h time.h tmpdir.h ttyent.h usersec.h \ 465 sys/un.h time.h tmpdir.h ttyent.h usersec.h \
483 util.h utime.h utmp.h utmpx.h vis.h) 466 util.h utime.h utmp.h utmpx.h)
484 467
485# Checks for libraries. 468# Checks for libraries.
486AC_CHECK_FUNC(yp_match, , AC_CHECK_LIB(nsl, yp_match)) 469AC_CHECK_FUNC(yp_match, , AC_CHECK_LIB(nsl, yp_match))
@@ -731,7 +714,7 @@ dnl Checks for library functions. Please keep in alphabetical order
731AC_CHECK_FUNCS(\ 714AC_CHECK_FUNCS(\
732 arc4random __b64_ntop b64_ntop __b64_pton b64_pton basename \ 715 arc4random __b64_ntop b64_ntop __b64_pton b64_pton basename \
733 bcopy bindresvport_sa clock fchmod fchown freeaddrinfo futimes \ 716 bcopy bindresvport_sa clock fchmod fchown freeaddrinfo futimes \
734 getaddrinfo getcwd getgrouplist getnameinfo getopt \ 717 gai_strerror getaddrinfo getcwd getgrouplist getnameinfo getopt \
735 getpeereid _getpty getrlimit getttyent glob inet_aton \ 718 getpeereid _getpty getrlimit getttyent glob inet_aton \
736 inet_ntoa inet_ntop innetgr login_getcapbool md5_crypt memmove \ 719 inet_ntoa inet_ntop innetgr login_getcapbool md5_crypt memmove \
737 mkdtemp mmap ngetaddrinfo nsleep ogetaddrinfo openlog_r openpty \ 720 mkdtemp mmap ngetaddrinfo nsleep ogetaddrinfo openlog_r openpty \
@@ -743,21 +726,6 @@ AC_CHECK_FUNCS(\
743 truncate utimes vhangup vsnprintf waitpid \ 726 truncate utimes vhangup vsnprintf waitpid \
744) 727)
745 728
746# IRIX has a const char return value for gai_strerror()
747AC_CHECK_FUNCS(gai_strerror,[
748 AC_DEFINE(HAVE_GAI_STRERROR)
749 AC_TRY_COMPILE([
750#include <sys/types.h>
751#include <sys/socket.h>
752#include <netdb.h>
753
754const char *gai_strerror(int);],[
755char *str;
756
757str = gai_strerror(0);],[
758 AC_DEFINE(HAVE_CONST_GAI_STRERROR_PROTO, 1,
759 [Define if gai_strerror() returns const char *])])])
760
761AC_SEARCH_LIBS(nanosleep, rt posix4, AC_DEFINE(HAVE_NANOSLEEP)) 729AC_SEARCH_LIBS(nanosleep, rt posix4, AC_DEFINE(HAVE_NANOSLEEP))
762 730
763dnl Make sure prototypes are defined for these before using them. 731dnl Make sure prototypes are defined for these before using them.
@@ -2215,15 +2183,11 @@ else
2215fi 2183fi
2216 2184
2217# check for /etc/default/login and use it if present. 2185# check for /etc/default/login and use it if present.
2218AC_ARG_ENABLE(etc-default-login,
2219 [ --disable-etc-default-login Disable using PATH from /etc/default/login [no]],,
2220[
2221AC_CHECK_FILE("/etc/default/login", [ external_path_file=/etc/default/login ]) 2186AC_CHECK_FILE("/etc/default/login", [ external_path_file=/etc/default/login ])
2222 2187
2223if test "x$external_path_file" = "x/etc/default/login"; then 2188if test "x$external_path_file" = "x/etc/default/login"; then
2224 AC_DEFINE(HAVE_ETC_DEFAULT_LOGIN) 2189 AC_DEFINE(HAVE_ETC_DEFAULT_LOGIN)
2225fi 2190fi
2226])
2227 2191
2228dnl BSD systems use /etc/login.conf so --with-default-path= has no effect 2192dnl BSD systems use /etc/login.conf so --with-default-path= has no effect
2229if test $ac_cv_func_login_getcapbool = "yes" -a \ 2193if test $ac_cv_func_login_getcapbool = "yes" -a \