summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1457b8a89..cdf24bc1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -545,6 +545,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
545 [Use tunnel device compatibility to OpenBSD]) 545 [Use tunnel device compatibility to OpenBSD])
546 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 546 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
547 [Prepend the address family to IP tunnel traffic]) 547 [Prepend the address family to IP tunnel traffic])
548 AC_MSG_CHECKING([if we have the Security Authorization Session API])
549 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
550 [SessionCreate(0, 0);],
551 [ac_cv_use_security_session_api="yes"
552 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
553 [platform has the Security Authorization Session API])
554 LIBS="$LIBS -framework Security"
555 AC_MSG_RESULT([yes])],
556 [ac_cv_use_security_session_api="no"
557 AC_MSG_RESULT([no])])
558 AC_MSG_CHECKING([if we have an in-memory credentials cache])
559 AC_TRY_COMPILE(
560 [#include <Kerberos/Kerberos.h>],
561 [cc_context_t c;
562 (void) cc_initialize (&c, 0, NULL, NULL);],
563 [AC_DEFINE([USE_CCAPI], [1],
564 [platform uses an in-memory credentials cache])
565 LIBS="$LIBS -framework Security"
566 AC_MSG_RESULT([yes])
567 if test "x$ac_cv_use_security_session_api" = "xno"; then
568 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
569 fi],
570 [AC_MSG_RESULT([no])]
571 )
548 m4_pattern_allow([AU_IPv]) 572 m4_pattern_allow([AU_IPv])
549 AC_CHECK_DECL([AU_IPv4], [], 573 AC_CHECK_DECL([AU_IPv4], [],
550 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 574 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])