diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 57 |
1 files changed, 57 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index 7a256034d..128889a28 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1448,6 +1448,62 @@ AC_ARG_WITH([skey], | |||
1448 | ] | 1448 | ] |
1449 | ) | 1449 | ) |
1450 | 1450 | ||
1451 | # Check whether user wants TCP wrappers support | ||
1452 | TCPW_MSG="no" | ||
1453 | AC_ARG_WITH([tcp-wrappers], | ||
1454 | [ --with-tcp-wrappers[[=PATH]] Enable tcpwrappers support (optionally in PATH)], | ||
1455 | [ | ||
1456 | if test "x$withval" != "xno" ; then | ||
1457 | saved_LIBS="$LIBS" | ||
1458 | saved_LDFLAGS="$LDFLAGS" | ||
1459 | saved_CPPFLAGS="$CPPFLAGS" | ||
1460 | if test -n "${withval}" && \ | ||
1461 | test "x${withval}" != "xyes"; then | ||
1462 | if test -d "${withval}/lib"; then | ||
1463 | if test -n "${need_dash_r}"; then | ||
1464 | LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}" | ||
1465 | else | ||
1466 | LDFLAGS="-L${withval}/lib ${LDFLAGS}" | ||
1467 | fi | ||
1468 | else | ||
1469 | if test -n "${need_dash_r}"; then | ||
1470 | LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}" | ||
1471 | else | ||
1472 | LDFLAGS="-L${withval} ${LDFLAGS}" | ||
1473 | fi | ||
1474 | fi | ||
1475 | if test -d "${withval}/include"; then | ||
1476 | CPPFLAGS="-I${withval}/include ${CPPFLAGS}" | ||
1477 | else | ||
1478 | CPPFLAGS="-I${withval} ${CPPFLAGS}" | ||
1479 | fi | ||
1480 | fi | ||
1481 | LIBS="-lwrap $LIBS" | ||
1482 | AC_MSG_CHECKING([for libwrap]) | ||
1483 | AC_LINK_IFELSE([AC_LANG_PROGRAM([[ | ||
1484 | #include <sys/types.h> | ||
1485 | #include <sys/socket.h> | ||
1486 | #include <netinet/in.h> | ||
1487 | #include <tcpd.h> | ||
1488 | int deny_severity = 0, allow_severity = 0; | ||
1489 | ]], [[ | ||
1490 | hosts_access(0); | ||
1491 | ]])], [ | ||
1492 | AC_MSG_RESULT([yes]) | ||
1493 | AC_DEFINE([LIBWRAP], [1], | ||
1494 | [Define if you want | ||
1495 | TCP Wrappers support]) | ||
1496 | SSHDLIBS="$SSHDLIBS -lwrap" | ||
1497 | TCPW_MSG="yes" | ||
1498 | ], [ | ||
1499 | AC_MSG_ERROR([*** libwrap missing]) | ||
1500 | |||
1501 | ]) | ||
1502 | LIBS="$saved_LIBS" | ||
1503 | fi | ||
1504 | ] | ||
1505 | ) | ||
1506 | |||
1451 | # Check whether user wants to use ldns | 1507 | # Check whether user wants to use ldns |
1452 | LDNS_MSG="no" | 1508 | LDNS_MSG="no" |
1453 | AC_ARG_WITH(ldns, | 1509 | AC_ARG_WITH(ldns, |
@@ -4953,6 +5009,7 @@ echo " KerberosV support: $KRB5_MSG" | |||
4953 | echo " SELinux support: $SELINUX_MSG" | 5009 | echo " SELinux support: $SELINUX_MSG" |
4954 | echo " Smartcard support: $SCARD_MSG" | 5010 | echo " Smartcard support: $SCARD_MSG" |
4955 | echo " S/KEY support: $SKEY_MSG" | 5011 | echo " S/KEY support: $SKEY_MSG" |
5012 | echo " TCP Wrappers support: $TCPW_MSG" | ||
4956 | echo " MD5 password support: $MD5_MSG" | 5013 | echo " MD5 password support: $MD5_MSG" |
4957 | echo " libedit support: $LIBEDIT_MSG" | 5014 | echo " libedit support: $LIBEDIT_MSG" |
4958 | echo " Solaris process contract support: $SPC_MSG" | 5015 | echo " Solaris process contract support: $SPC_MSG" |