summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 274111e2c..a232a746b 100644
--- a/configure.in
+++ b/configure.in
@@ -177,6 +177,18 @@ AC_TRY_COMPILE(
177 [AC_MSG_RESULT(no)] 177 [AC_MSG_RESULT(no)]
178) 178)
179 179
180AC_MSG_CHECKING([For socklen_t])
181AC_TRY_COMPILE(
182 [#include <sys/types.h>],
183 [#include <sys/socket.h>],
184 [socklen_t foo; foo = 1235;],
185 [
186 AC_DEFINE(HAVE_SOCKLEN_T)
187 AC_MSG_RESULT(yes)
188 ],
189 [AC_MSG_RESULT(no)]
190)
191
180AC_ARG_WITH(pam, 192AC_ARG_WITH(pam,
181 [ --without-pam Disable PAM support ], 193 [ --without-pam Disable PAM support ],
182 [ 194 [