summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in41
1 files changed, 40 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f0edebacc..3671f50cf 100644
--- a/configure.in
+++ b/configure.in
@@ -102,6 +102,17 @@ case "$host" in
102*-*-netbsd*) 102*-*-netbsd*)
103 need_dash_r=1 103 need_dash_r=1
104 ;; 104 ;;
105*-next-*)
106 # hardwire lastlog location (can't detect it on some versions)
107 conf_lastlog_location="/usr/adm/lastlog"
108 AC_DEFINE(HAVE_NEXT)
109 CFLAGS="$CFLAGS -I/usr/local/include"
110 MAIL=/usr/spool/mail
111 conf_utmp_location=/etc/utmp
112 AC_MSG_WARN([*** Tested: PA-RISC/m68k Untested: Sparc/Intel])
113 AC_MSG_WARN([*** Expect 'scp' to fail!])
114 AC_MSG_WARN([*** Please report any problems, thanks])
115 ;;
105*-*-solaris*) 116*-*-solaris*)
106 CFLAGS="$CFLAGS -I/usr/local/include" 117 CFLAGS="$CFLAGS -I/usr/local/include"
107 LDFLAGS="$LDFLAGS -L/usr/local/lib -R/usr/local/lib -L/usr/ucblib -R/usr/ucblib" 118 LDFLAGS="$LDFLAGS -L/usr/local/lib -R/usr/local/lib -L/usr/ucblib -R/usr/ucblib"
@@ -178,7 +189,7 @@ if test -z "$no_libnsl" ; then
178fi 189fi
179 190
180# Checks for header files. 191# Checks for header files.
181AC_CHECK_HEADERS(bstring.h endian.h lastlog.h limits.h login.h maillock.h netdb.h netgroup.h netinet/in_systm.h paths.h poll.h pty.h shadow.h security/pam_appl.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h sys/poll.h sys/select.h sys/stropts.h sys/sysmacros.h sys/time.h sys/ttcompat.h stddef.h time.h util.h utmp.h utmpx.h) 192AC_CHECK_HEADERS(bstring.h endian.h lastlog.h limits.h login.h maillock.h netdb.h netgroup.h netinet/in_systm.h paths.h poll.h pty.h shadow.h security/pam_appl.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h sys/poll.h sys/select.h sys/stat.h sys/stropts.h sys/sysmacros.h sys/time.h sys/ttcompat.h stddef.h time.h util.h utmp.h utmpx.h)
182 193
183# Checks for library functions. 194# Checks for library functions.
184AC_CHECK_FUNCS(arc4random atexit b64_ntop bcopy bindresvport_af clock freeaddrinfo gai_strerror getaddrinfo getnameinfo getrusage innetgr md5_crypt memmove mkdtemp on_exit openpty rresvport_af setenv seteuid setlogin setproctitle setreuid snprintf strlcat strlcpy vsnprintf vhangup _getpty __b64_ntop) 195AC_CHECK_FUNCS(arc4random atexit b64_ntop bcopy bindresvport_af clock freeaddrinfo gai_strerror getaddrinfo getnameinfo getrusage innetgr md5_crypt memmove mkdtemp on_exit openpty rresvport_af setenv seteuid setlogin setproctitle setreuid snprintf strlcat strlcpy vsnprintf vhangup _getpty __b64_ntop)
@@ -491,6 +502,34 @@ if test "x$ac_cv_have_ssize_t" = "xyes" ; then
491 AC_DEFINE(HAVE_SSIZE_T) 502 AC_DEFINE(HAVE_SSIZE_T)
492fi 503fi
493 504
505AC_CACHE_CHECK([for pid_t], ac_cv_have_pid_t, [
506 AC_TRY_COMPILE(
507 [
508#include <sys/types.h>
509 ],
510 [ pid_t foo; foo = 1235; ],
511 [ ac_cv_have_pid_t="yes" ],
512 [ ac_cv_have_pid_t="no" ]
513 )
514])
515if test "x$ac_cv_have_pid_t" = "xyes" ; then
516 AC_DEFINE(HAVE_PID_T)
517fi
518
519AC_CACHE_CHECK([for mode_t], ac_cv_have_mode_t, [
520 AC_TRY_COMPILE(
521 [
522#include <sys/types.h>
523 ],
524 [ mode_t foo; foo = 1235; ],
525 [ ac_cv_have_mode_t="yes" ],
526 [ ac_cv_have_mode_t="no" ]
527 )
528])
529if test "x$ac_cv_have_mode_t" = "xyes" ; then
530 AC_DEFINE(HAVE_MODE_T)
531fi
532
494 533
495AC_CACHE_CHECK([for struct sockaddr_storage], ac_cv_have_struct_sockaddr_storage, [ 534AC_CACHE_CHECK([for struct sockaddr_storage], ac_cv_have_struct_sockaddr_storage, [
496 AC_TRY_COMPILE( 535 AC_TRY_COMPILE(