summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 16 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 1ee188565..82cb5d4bd 100644
--- a/configure.in
+++ b/configure.in
@@ -313,10 +313,10 @@ AC_CHECK_FUNC(utimes,
313) 313)
314 314
315# Checks for header files. 315# Checks for header files.
316AC_CHECK_HEADERS(bstring.h endian.h floatingpoint.h getopt.h lastlog.h limits.h login.h login_cap.h maillock.h netdb.h netgroup.h netinet/in_systm.h paths.h poll.h pty.h shadow.h security/pam_appl.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h sys/poll.h sys/queue.h sys/select.h sys/stat.h sys/stropts.h sys/sysmacros.h sys/time.h sys/ttcompat.h sys/un.h stddef.h time.h ttyent.h usersec.h util.h utmp.h utmpx.h vis.h) 316AC_CHECK_HEADERS(bstring.h endian.h floatingpoint.h getopt.h lastlog.h limits.h login.h login_cap.h maillock.h netdb.h netgroup.h netinet/in_systm.h paths.h poll.h pty.h shadow.h security/pam_appl.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h sys/poll.h sys/queue.h sys/select.h sys/stat.h sys/stropts.h sys/sysmacros.h sys/time.h sys/ttcompat.h sys/un.h stddef.h time.h ttyent.h usersec.h util.h utime.h utmp.h utmpx.h vis.h)
317 317
318dnl Checks for library functions. 318dnl Checks for library functions.
319AC_CHECK_FUNCS(arc4random atexit b64_ntop bcopy bindresvport_af clock fchmod freeaddrinfo futimes gai_strerror getcwd getaddrinfo getgrouplist getnameinfo getrlimit getrusage getttyent inet_aton inet_ntoa innetgr login_getcapbool md5_crypt memmove mkdtemp on_exit openpty realpath rresvport_af setdtablesize setenv seteuid setlogin setproctitle setreuid setrlimit setsid sigaction sigvec snprintf strerror strlcat strlcpy strsep strtok_r sysconf vsnprintf vhangup vis waitpid _getpty __b64_ntop) 319AC_CHECK_FUNCS(arc4random atexit b64_ntop bcopy bindresvport_af clock fchmod freeaddrinfo futimes gai_strerror getcwd getaddrinfo getgrouplist getnameinfo getrlimit getrusage getttyent inet_aton inet_ntoa innetgr login_getcapbool md5_crypt memmove mkdtemp on_exit openpty realpath rresvport_af setdtablesize setenv seteuid setlogin setproctitle setreuid setrlimit setsid sigaction sigvec snprintf strerror strlcat strlcpy strsep strtok_r sysconf utimes vsnprintf vhangup vis waitpid _getpty __b64_ntop)
320dnl Checks for time functions 320dnl Checks for time functions
321AC_CHECK_FUNCS(gettimeofday time) 321AC_CHECK_FUNCS(gettimeofday time)
322dnl Checks for libutil functions 322dnl Checks for libutil functions
@@ -825,14 +825,27 @@ if test "x$ac_cv_have_struct_addrinfo" = "xyes" ; then
825 AC_DEFINE(HAVE_STRUCT_ADDRINFO) 825 AC_DEFINE(HAVE_STRUCT_ADDRINFO)
826fi 826fi
827 827
828AC_CACHE_CHECK([for struct timeval], ac_cv_have_struct_timeval, [
829 AC_TRY_COMPILE(
830 [ #include <sys/time.h> ],
831 [ struct timeval tv; tv.tv_sec = 1;],
832 [ ac_cv_have_struct_timeval="yes" ],
833 [ ac_cv_have_struct_timeval="no" ]
834 )
835])
836if test "x$ac_cv_have_struct_timeval" = "xyes" ; then
837 AC_DEFINE(HAVE_STRUCT_TIMEVAL)
838 have_struct_timeval=1
839fi
840
828# If we don't have int64_t then we can't compile sftp-server. So don't 841# If we don't have int64_t then we can't compile sftp-server. So don't
829# even attempt to do it. 842# even attempt to do it.
830if test "x$ac_cv_have_int64_t" = "xno" -a \ 843if test "x$ac_cv_have_int64_t" = "xno" -a \
831 "x$ac_cv_sizeof_long_int" != "x8" -a \ 844 "x$ac_cv_sizeof_long_int" != "x8" -a \
832 "x$ac_cv_sizeof_long_long_int" = "x0" ; then 845 "x$ac_cv_sizeof_long_long_int" = "x0" ; then
833 NO_SFTP='#' 846 NO_SFTP='#'
834 AC_SUBST(NO_SFTP)
835fi 847fi
848AC_SUBST(NO_SFTP)
836 849
837dnl Checks for structure members 850dnl Checks for structure members
838OSSH_CHECK_HEADER_FOR_FIELD(ut_host, utmp.h, HAVE_HOST_IN_UTMP) 851OSSH_CHECK_HEADER_FOR_FIELD(ut_host, utmp.h, HAVE_HOST_IN_UTMP)