summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index cbc866ad5..a5870f336 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
1# $Id: configure.in,v 1.246 2001/02/18 04:29:29 djm Exp $ 1# $Id: configure.in,v 1.247 2001/02/18 06:01:00 djm Exp $
2 2
3AC_INIT(ssh.c) 3AC_INIT(ssh.c)
4 4
@@ -1411,6 +1411,17 @@ AC_ARG_WITH(4in6,
1411 ] 1411 ]
1412) 1412)
1413 1413
1414# Whether to enable BSD auth support
1415AC_ARG_WITH(bsd-auth,
1416 [ --with-bsd-auth Enable BSD auth support],
1417 [
1418 if test "x$withval" != "xno" ; then
1419 AC_DEFINE(BSD_AUTH)
1420 bsd_auth=yes
1421 fi
1422 ]
1423)
1424
1414AC_MSG_CHECKING(whether to install ssh as suid root) 1425AC_MSG_CHECKING(whether to install ssh as suid root)
1415AC_ARG_ENABLE(suid-ssh, 1426AC_ARG_ENABLE(suid-ssh,
1416[ --enable-suid-ssh Install ssh as suid root (default) 1427[ --enable-suid-ssh Install ssh as suid root (default)
@@ -1739,6 +1750,10 @@ echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
1739echo " Use IPv4 by default hack: $IPV4_HACK_MSG" 1750echo " Use IPv4 by default hack: $IPV4_HACK_MSG"
1740echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 1751echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
1741 1752
1753if test ! -z "$bsd_auth"; then
1754 echo " BSD Auth support: yes"
1755fi
1756
1742echo "" 1757echo ""
1743 1758
1744echo " Host: ${host}" 1759echo " Host: ${host}"
@@ -1769,3 +1784,4 @@ if test ! -z "$NO_SFTP"; then
1769 echo "64bit integers." 1784 echo "64bit integers."
1770 echo "" 1785 echo ""
1771fi 1786fi
1787