summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in37
1 files changed, 37 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 05a354d1a..0b54fd58a 100644
--- a/configure.in
+++ b/configure.in
@@ -166,4 +166,41 @@ AC_TRY_LINK([],
166 ] 166 ]
167) 167)
168 168
169dnl Check whether user wants Kerberos support
170AC_ARG_WITH(kerberos4,
171 [ --with-kerberos4 Enable Kerberos 4 support],
172 [
173 AC_DEFINE(KRB4)
174 LIBS="$LIBS -lkrb"
175 CFLAGS="$CFLAGS -I/usr/include/kerberosIV"
176 ]
177)
178
179dnl Check whether user wants AFS support
180AC_ARG_WITH(kerberos4,
181 [ --with-afs Enable AFS support],
182 [
183 AC_DEFINE(AFS)
184 LIBS="$LIBS -lkafs"
185 ]
186)
187
188dnl Check whether user wants S/Key support
189AC_ARG_WITH(skey,
190 [ --with-skey Enable S/Key support],
191 [
192 AC_DEFINE(SKEY)
193 LIBS="$LIBS -lskey"
194 ]
195)
196
197dnl Check whether user wants TCP wrappers support
198AC_ARG_WITH(skey,
199 [ --with-tcp-wrappers Enable tcpwrappers support],
200 [
201 AC_DEFINE(LIBWRAP)
202 LIBS="$LIBS -lwrap"
203 ]
204)
205
169AC_OUTPUT(Makefile) 206AC_OUTPUT(Makefile)