summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 02287b802..824ff5c02 100644
--- a/configure.in
+++ b/configure.in
@@ -465,6 +465,19 @@ AC_CHECK_SIZEOF(long int, 4)
465AC_CHECK_SIZEOF(long long int, 8) 465AC_CHECK_SIZEOF(long long int, 8)
466 466
467# More checks for data types 467# More checks for data types
468AC_CACHE_CHECK([for u_int type], ac_cv_have_u_int, [
469 AC_TRY_COMPILE(
470 [ #include <sys/types.h> ],
471 [ u_int a; a = 1;],
472 [ ac_cv_have_u_int="yes" ],
473 [ ac_cv_have_u_int="no" ]
474 )
475])
476if test "x$ac_cv_have_u_int" = "xyes" ; then
477 AC_DEFINE(HAVE_U_INT)
478 have_u_int=1
479fi
480
468AC_CACHE_CHECK([for intXX_t types], ac_cv_have_intxx_t, [ 481AC_CACHE_CHECK([for intXX_t types], ac_cv_have_intxx_t, [
469 AC_TRY_COMPILE( 482 AC_TRY_COMPILE(
470 [ #include <sys/types.h> ], 483 [ #include <sys/types.h> ],
@@ -491,7 +504,6 @@ if test "x$ac_cv_have_u_intxx_t" = "xyes" ; then
491 have_u_intxx_t=1 504 have_u_intxx_t=1
492fi 505fi
493 506
494
495if (test -z "$have_u_intxx_t" || test -z "$have_intxx_t" && \ 507if (test -z "$have_u_intxx_t" || test -z "$have_intxx_t" && \
496 test "x$ac_cv_header_sys_bitypes_h" = "xyes") 508 test "x$ac_cv_header_sys_bitypes_h" = "xyes")
497then 509then