summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0b8047a36..92659857c 100644
--- a/configure.in
+++ b/configure.in
@@ -216,10 +216,10 @@ if test -z "$no_libnsl" ; then
216fi 216fi
217 217
218# Checks for header files. 218# Checks for header files.
219AC_CHECK_HEADERS(bstring.h endian.h lastlog.h limits.h login.h maillock.h netdb.h netgroup.h netinet/in_systm.h paths.h poll.h pty.h shadow.h security/pam_appl.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h sys/poll.h sys/select.h sys/stat.h sys/stropts.h sys/sysmacros.h sys/time.h sys/ttcompat.h stddef.h time.h usersec.h util.h utmp.h utmpx.h) 219AC_CHECK_HEADERS(bstring.h endian.h floatingpoint.h lastlog.h limits.h login.h maillock.h netdb.h netgroup.h netinet/in_systm.h paths.h poll.h pty.h shadow.h security/pam_appl.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h sys/poll.h sys/select.h sys/stat.h sys/stropts.h sys/sysmacros.h sys/time.h sys/ttcompat.h stddef.h time.h usersec.h util.h utmp.h utmpx.h)
220 220
221# Checks for library functions. 221# Checks for library functions.
222AC_CHECK_FUNCS(arc4random atexit b64_ntop bcopy bindresvport_af clock freeaddrinfo gai_strerror getaddrinfo getnameinfo getrusage inet_aton innetgr md5_crypt memmove mkdtemp on_exit openpty rresvport_af setenv seteuid setlogin setproctitle setreuid sigaction sigvec snprintf strlcat strlcpy strsep vsnprintf vhangup _getpty __b64_ntop) 222AC_CHECK_FUNCS(arc4random atexit b64_ntop bcopy bindresvport_af clock freeaddrinfo gai_strerror getaddrinfo getnameinfo getrusage inet_aton innetgr md5_crypt memmove mkdtemp on_exit openpty rresvport_af setenv seteuid setlogin setproctitle setreuid sigaction sigvec snprintf strerror strlcat strlcpy strsep vsnprintf vhangup _getpty __b64_ntop)
223dnl checks for time functions 223dnl checks for time functions
224AC_CHECK_FUNCS(gettimeofday time) 224AC_CHECK_FUNCS(gettimeofday time)
225dnl checks for libutil functions 225dnl checks for libutil functions
@@ -724,6 +724,18 @@ if test "x$ac_cv_libc_defines___progname" = "xyes" ; then
724fi 724fi
725 725
726 726
727AC_CACHE_CHECK([if libc defines sys_errlist], ac_cv_libc_defines_sys_errlist, [
728 AC_TRY_LINK([],
729 [ extern const char *const sys_errlist[]; printf("%s", sys_errlist[0]);],
730 [ ac_cv_libc_defines_sys_errlist="yes" ],
731 [ ac_cv_libc_defines_sys_errlist="no" ]
732 )
733])
734if test "x$ac_cv_libc_defines_sys_errlist" = "xyes" ; then
735 AC_DEFINE(HAVE_SYS_ERRLIST)
736fi
737
738
727# Looking for programs, paths and files 739# Looking for programs, paths and files
728AC_ARG_WITH(rsh, 740AC_ARG_WITH(rsh,
729 [ --with-rsh=PATH Specify path to remote shell program ], 741 [ --with-rsh=PATH Specify path to remote shell program ],