diff options
Diffstat (limited to 'configure.in')
-rw-r--r-- | configure.in | 55 |
1 files changed, 30 insertions, 25 deletions
diff --git a/configure.in b/configure.in index 90ed2bb80..4158b99b2 100644 --- a/configure.in +++ b/configure.in | |||
@@ -51,6 +51,31 @@ if test "$GCC" = "yes"; then CFLAGS="$CFLAGS -Wall"; fi | |||
51 | 51 | ||
52 | AC_C_INLINE | 52 | AC_C_INLINE |
53 | 53 | ||
54 | dnl Check for OpenSSL/SSLeay directories. | ||
55 | AC_MSG_CHECKING([for OpenSSL/SSLeay directory]) | ||
56 | for ssldir in $prefix /usr /usr/local/openssl /usr/lib/openssl /usr/local/ssl /usr/lib/ssl /usr/local $prefix /usr/pkg ; do | ||
57 | if test -f "$ssldir/include/openssl/crypto.h"; then | ||
58 | AC_DEFINE(HAVE_OPENSSL) | ||
59 | GOT_SSL="yes" | ||
60 | break | ||
61 | fi | ||
62 | if test -f "$ssldir/include/ssl/crypto.h"; then | ||
63 | AC_DEFINE(HAVE_SSL) | ||
64 | GOT_SSL="yes" | ||
65 | break | ||
66 | fi | ||
67 | done | ||
68 | if test -z "$GOT_SSL" ; then | ||
69 | AC_MSG_ERROR([Could not find SSLeay / OpenSSL libraries, please install]) | ||
70 | fi | ||
71 | AC_SUBST(ssldir) | ||
72 | AC_DEFINE_UNQUOTED(ssldir, "$ssldir") | ||
73 | if test "$ssldir" != "/usr"; then | ||
74 | CFLAGS="$CFLAGS -I$ssldir/include" | ||
75 | LDFLAGS="$LDFLAGS -L$ssldir/lib" | ||
76 | fi | ||
77 | AC_MSG_RESULT($ssldir) | ||
78 | |||
54 | dnl Check for some target-specific stuff | 79 | dnl Check for some target-specific stuff |
55 | case "$host" in | 80 | case "$host" in |
56 | *-*-aix*) | 81 | *-*-aix*) |
@@ -87,6 +112,11 @@ case "$host" in | |||
87 | *-*-linux*) | 112 | *-*-linux*) |
88 | no_dev_ptmx=1 | 113 | no_dev_ptmx=1 |
89 | ;; | 114 | ;; |
115 | *-*-netbsd*) | ||
116 | if test "$GOT_SSL" = "yes"; then | ||
117 | LDFLAGS="$LDFLAGS -R$ssldir/lib" | ||
118 | fi | ||
119 | ;; | ||
90 | *-*-solaris*) | 120 | *-*-solaris*) |
91 | AC_DEFINE(USE_UTMPX) | 121 | AC_DEFINE(USE_UTMPX) |
92 | ;; | 122 | ;; |
@@ -95,31 +125,6 @@ case "$host" in | |||
95 | ;; | 125 | ;; |
96 | esac | 126 | esac |
97 | 127 | ||
98 | dnl Check for OpenSSL/SSLeay directories. | ||
99 | AC_MSG_CHECKING([for OpenSSL/SSLeay directory]) | ||
100 | for ssldir in $prefix /usr /usr/local/openssl /usr/lib/openssl /usr/local/ssl /usr/lib/ssl /usr/local $prefix /usr/pkg ; do | ||
101 | if test -f "$ssldir/include/openssl/crypto.h"; then | ||
102 | AC_DEFINE(HAVE_OPENSSL) | ||
103 | GOT_SSL="yes" | ||
104 | break | ||
105 | fi | ||
106 | if test -f "$ssldir/include/ssl/crypto.h"; then | ||
107 | AC_DEFINE(HAVE_SSL) | ||
108 | GOT_SSL="yes" | ||
109 | break | ||
110 | fi | ||
111 | done | ||
112 | if test -z "$GOT_SSL" ; then | ||
113 | AC_MSG_ERROR([Could not find SSLeay / OpenSSL libraries, please install]) | ||
114 | fi | ||
115 | AC_SUBST(ssldir) | ||
116 | AC_DEFINE_UNQUOTED(ssldir, "$ssldir") | ||
117 | if test "$ssldir" != "/usr"; then | ||
118 | CFLAGS="$CFLAGS -I$ssldir/include" | ||
119 | LDFLAGS="$LDFLAGS -L$ssldir/lib" | ||
120 | fi | ||
121 | AC_MSG_RESULT($ssldir) | ||
122 | |||
123 | dnl Check for RSAref library. | 128 | dnl Check for RSAref library. |
124 | AC_MSG_CHECKING([for RSAref library]) | 129 | AC_MSG_CHECKING([for RSAref library]) |
125 | saved_LIBS="$LIBS" | 130 | saved_LIBS="$LIBS" |