summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 7ad0d01d7..974d0df6b 100644
--- a/configure.in
+++ b/configure.in
@@ -87,6 +87,7 @@ case "$host" in
87 MANTYPE='$(CATMAN)' 87 MANTYPE='$(CATMAN)'
88 no_libsocket=1 88 no_libsocket=1
89 no_libnsl=1 89 no_libnsl=1
90 AC_DEFINE(BROKEN_INET_NTOA)
90 ;; 91 ;;
91*-*-irix6*) 92*-*-irix6*)
92 CFLAGS="$CFLAGS -I/usr/local/include" 93 CFLAGS="$CFLAGS -I/usr/local/include"
@@ -97,6 +98,7 @@ case "$host" in
97 AC_DEFINE(WITH_IRIX_AUDIT) 98 AC_DEFINE(WITH_IRIX_AUDIT)
98 no_libsocket=1 99 no_libsocket=1
99 no_libnsl=1 100 no_libnsl=1
101 AC_DEFINE(BROKEN_INET_NTOA)
100 ;; 102 ;;
101*-*-linux*) 103*-*-linux*)
102 no_dev_ptmx=1 104 no_dev_ptmx=1
@@ -224,7 +226,7 @@ fi
224AC_CHECK_HEADERS(bstring.h endian.h floatingpoint.h lastlog.h limits.h login.h maillock.h netdb.h netgroup.h netinet/in_systm.h paths.h poll.h pty.h shadow.h security/pam_appl.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h sys/poll.h sys/select.h sys/stat.h sys/stropts.h sys/sysmacros.h sys/time.h sys/ttcompat.h stddef.h time.h ttyent.h usersec.h util.h utmp.h utmpx.h) 226AC_CHECK_HEADERS(bstring.h endian.h floatingpoint.h lastlog.h limits.h login.h maillock.h netdb.h netgroup.h netinet/in_systm.h paths.h poll.h pty.h shadow.h security/pam_appl.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h sys/poll.h sys/select.h sys/stat.h sys/stropts.h sys/sysmacros.h sys/time.h sys/ttcompat.h stddef.h time.h ttyent.h usersec.h util.h utmp.h utmpx.h)
225 227
226# Checks for library functions. 228# Checks for library functions.
227AC_CHECK_FUNCS(arc4random atexit b64_ntop bcopy bindresvport_af clock freeaddrinfo gai_strerror getaddrinfo getnameinfo getrusage getttyent inet_aton innetgr md5_crypt memmove mkdtemp on_exit openpty rresvport_af setenv seteuid setlogin setproctitle setreuid sigaction sigvec snprintf strerror strlcat strlcpy strsep vsnprintf vhangup _getpty __b64_ntop) 229AC_CHECK_FUNCS(arc4random atexit b64_ntop bcopy bindresvport_af clock freeaddrinfo gai_strerror getaddrinfo getnameinfo getrusage getttyent inet_aton inet_ntoa innetgr md5_crypt memmove mkdtemp on_exit openpty rresvport_af setenv seteuid setlogin setproctitle setreuid sigaction sigvec snprintf strerror strlcat strlcpy strsep vsnprintf vhangup _getpty __b64_ntop)
228dnl checks for time functions 230dnl checks for time functions
229AC_CHECK_FUNCS(gettimeofday time) 231AC_CHECK_FUNCS(gettimeofday time)
230dnl checks for libutil functions 232dnl checks for libutil functions
@@ -741,6 +743,18 @@ if test "x$ac_cv_libc_defines_sys_errlist" = "xyes" ; then
741fi 743fi
742 744
743 745
746AC_CACHE_CHECK([if libc defines sys_nerr], ac_cv_libc_defines_sys_nerr, [
747 AC_TRY_LINK([],
748 [ extern int sys_nerr; printf("%i", sys_nerr);],
749 [ ac_cv_libc_defines_sys_nerr="yes" ],
750 [ ac_cv_libc_defines_sys_nerr="no" ]
751 )
752])
753if test "x$ac_cv_libc_defines_sys_nerr" = "xyes" ; then
754 AC_DEFINE(HAVE_SYS_NERR)
755fi
756
757
744# Looking for programs, paths and files 758# Looking for programs, paths and files
745AC_ARG_WITH(rsh, 759AC_ARG_WITH(rsh,
746 [ --with-rsh=PATH Specify path to remote shell program ], 760 [ --with-rsh=PATH Specify path to remote shell program ],