summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c9bd33b02..4b5ee92cf 100644
--- a/configure.in
+++ b/configure.in
@@ -699,8 +699,25 @@ AC_ARG_WITH(tcp-wrappers,
699 [ --with-tcp-wrappers Enable tcpwrappers support], 699 [ --with-tcp-wrappers Enable tcpwrappers support],
700 [ 700 [
701 if test "x$withval" != "$xno" ; then 701 if test "x$withval" != "$xno" ; then
702 AC_DEFINE(LIBWRAP) 702 saved_LIBS="$LIBS"
703 LIBS="$LIBS -lwrap" 703 LIBS="$LIBS -lwrap"
704 AC_MSG_CHECKING(for libwrap)
705 AC_TRY_LINK(
706 [
707 #include <tcpd.h>
708 int deny_severity = 0, allow_severity = 0;
709 ],
710 [hosts_access(0);],
711 [
712 AC_MSG_RESULT(yes)
713 AC_DEFINE(LIBWRAP)
714 ],
715 [
716 AC_MSG_RESULT(no)
717 AC_MSG_WARN([*** libwrap missing - tcpwrapper support disabled ***])
718 LIBS="$saved_LIBS"
719 ]
720 )
704 fi 721 fi
705 ] 722 ]
706) 723)