summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8e155f26b..dbc5a18ee 100644
--- a/configure.in
+++ b/configure.in
@@ -235,6 +235,23 @@ AC_CHECK_FUNC(getpagesize,
235 [AC_CHECK_LIB(ucb, getpagesize, [LIBS="$LIBS -lucb"; AC_DEFINE(HAVE_GETPAGESIZE)])] 235 [AC_CHECK_LIB(ucb, getpagesize, [LIBS="$LIBS -lucb"; AC_DEFINE(HAVE_GETPAGESIZE)])]
236) 236)
237 237
238# Check for broken snprintf
239if test "x$ac_cv_func_snprintf" = "xyes" ; then
240 AC_MSG_CHECKING([whether snprintf correctly terminates long strings])
241 AC_TRY_RUN(
242 [
243#include <stdio.h>
244int main(void){char b[5];snprintf(b,5,"123456789");return(b[4]!='\0');}
245 ],
246 [AC_MSG_RESULT(yes)],
247 [
248 AC_MSG_RESULT(no)
249 AC_DEFINE(BROKEN_SNPRINTF)
250 AC_MSG_WARN([****** Your snprintf() function is broken, complain to your vendor])
251 ]
252 )
253fi
254
238PAM_MSG="no" 255PAM_MSG="no"
239AC_ARG_WITH(pam, 256AC_ARG_WITH(pam,
240 [ --without-pam Disable PAM support ], 257 [ --without-pam Disable PAM support ],