summaryrefslogtreecommitdiff
path: root/contrib/redhat/openssh.spec
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/redhat/openssh.spec')
-rw-r--r--contrib/redhat/openssh.spec26
1 files changed, 10 insertions, 16 deletions
diff --git a/contrib/redhat/openssh.spec b/contrib/redhat/openssh.spec
index e1feb778e..e593f2813 100644
--- a/contrib/redhat/openssh.spec
+++ b/contrib/redhat/openssh.spec
@@ -1,5 +1,5 @@
1# Version of OpenSSH 1# Version of OpenSSH
2%define oversion 2.1.1p4 2%define oversion 2.1.1p5
3 3
4# Version of ssh-askpass 4# Version of ssh-askpass
5%define aversion 1.0 5%define aversion 1.0
@@ -14,9 +14,9 @@ Summary: OpenSSH free Secure Shell (SSH) implementation
14Name: openssh 14Name: openssh
15Version: %{oversion} 15Version: %{oversion}
16Release: 1 16Release: 1
17Packager: Damien Miller <djm@ibs.com.au> 17Packager: Damien Miller <djm@mindrot.org>
18URL: http://www.openssh.com/ 18URL: http://www.openssh.com/
19Source0: http://violet.ibs.com.au/openssh/files/openssh-%{oversion}.tar.gz 19Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{oversion}.tar.gz
20Source1: http://www.ntrnet.net/~jmknoble/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz 20Source1: http://www.ntrnet.net/~jmknoble/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
21Copyright: BSD 21Copyright: BSD
22Group: Applications/Internet 22Group: Applications/Internet
@@ -27,14 +27,14 @@ Requires: openssl >= 0.9.5a
27BuildPreReq: perl 27BuildPreReq: perl
28BuildPreReq: openssl-devel 28BuildPreReq: openssl-devel
29BuildPreReq: tcp_wrappers 29BuildPreReq: tcp_wrappers
30%if ! %{no_x11_askpass} 30%if ! %{no_gnome_askpass}
31BuildPreReq: gnome-libs-devel 31BuildPreReq: gnome-libs-devel
32%endif 32%endif
33 33
34%package clients 34%package clients
35Summary: OpenSSH Secure Shell protocol clients 35Summary: OpenSSH Secure Shell protocol clients
36Requires: openssh 36Requires: openssh
37Group: System Environment/Daemons 37Group: Applications/Internet
38Obsoletes: ssh-clients 38Obsoletes: ssh-clients
39 39
40%package server 40%package server
@@ -127,6 +127,9 @@ patented algorithms to seperate libraries (OpenSSL).
127This package contains the GNOME passphrase dialog. 127This package contains the GNOME passphrase dialog.
128 128
129%changelog 129%changelog
130* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
131- Some surgery to sshd.init (generate keys at runtime)
132- Cleanup of groups and removal of keygen calls
130* Wed Jul 12 2000 Damien Miller <djm@mindrot.org> 133* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
131- Make building of X11-askpass and gnome-askpass optional 134- Make building of X11-askpass and gnome-askpass optional
132* Mon Jun 12 2000 Damien Miller <djm@mindrot.org> 135* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
@@ -208,20 +211,12 @@ rm -rf $RPM_BUILD_ROOT
208 211
209%post server 212%post server
210/sbin/chkconfig --add sshd 213/sbin/chkconfig --add sshd
211if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then 214if test -r /var/run/sshd.pid ; then
212 /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
213fi
214if [ ! -f /etc/ssh/ssh_host_dsa_key -o ! -s /etc/ssh/ssh_host_dsa_key ]; then
215 /usr/bin/ssh-keygen -d -f /etc/ssh/ssh_host_dsa_key -N '' >&2
216fi
217if test -r /var/run/sshd.pid
218then
219 /etc/rc.d/init.d/sshd restart >&2 215 /etc/rc.d/init.d/sshd restart >&2
220fi 216fi
221 217
222%preun server 218%preun server
223if [ "$1" = 0 ] 219if [ "$1" = 0 ] ; then
224then
225 /etc/rc.d/init.d/sshd stop >&2 220 /etc/rc.d/init.d/sshd stop >&2
226 /sbin/chkconfig --del sshd 221 /sbin/chkconfig --del sshd
227fi 222fi
@@ -272,4 +267,3 @@ fi
272%defattr(-,root,root) 267%defattr(-,root,root)
273%attr(0755,root,root) /usr/libexec/ssh/gnome-ssh-askpass 268%attr(0755,root,root) /usr/libexec/ssh/gnome-ssh-askpass
274%endif 269%endif
275