summaryrefslogtreecommitdiff
path: root/contrib/redhat/openssh.spec
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/redhat/openssh.spec')
-rw-r--r--contrib/redhat/openssh.spec27
1 files changed, 14 insertions, 13 deletions
diff --git a/contrib/redhat/openssh.spec b/contrib/redhat/openssh.spec
index ce7c564c3..e7c3bb121 100644
--- a/contrib/redhat/openssh.spec
+++ b/contrib/redhat/openssh.spec
@@ -1,4 +1,4 @@
1%define ver 3.7p1 1%define ver 3.6.1p2
2%define rel 1 2%define rel 1
3 3
4# OpenSSH privilege separation requires a user & group ID 4# OpenSSH privilege separation requires a user & group ID
@@ -26,6 +26,9 @@
26# Is this build for RHL 6.x? 26# Is this build for RHL 6.x?
27%define build6x 0 27%define build6x 0
28 28
29# Disable IPv6 (avoids DNS hangs on some glibc versions)
30%define noip6 0
31
29# Do we want kerberos5 support (1=yes 0=no) 32# Do we want kerberos5 support (1=yes 0=no)
30%define kerberos5 1 33%define kerberos5 1
31 34
@@ -40,6 +43,7 @@
40# If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc. 43# If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
41%if %{build6x} 44%if %{build6x}
42%define _sysconfdir /etc 45%define _sysconfdir /etc
46%define noip6 1
43%endif 47%endif
44 48
45# Options for static OpenSSL link: 49# Options for static OpenSSL link:
@@ -50,6 +54,10 @@
50# rpm -ba|--rebuild --define "smartcard 1" 54# rpm -ba|--rebuild --define "smartcard 1"
51%{?smartcard:%define scard 1} 55%{?smartcard:%define scard 1}
52 56
57# Option to disable ipv6
58# rpm -ba|--rebuild --define "noipv6 1"
59%{?noipv6:%define noip6 1}
60
53# Is this a build for the rescue CD (without PAM, with MD5)? (1=yes 0=no) 61# Is this a build for the rescue CD (without PAM, with MD5)? (1=yes 0=no)
54%define rescue 0 62%define rescue 0
55%{?build_rescue:%define rescue 1} 63%{?build_rescue:%define rescue 1}
@@ -79,12 +87,12 @@ PreReq: initscripts >= 5.00
79%else 87%else
80PreReq: initscripts >= 5.20 88PreReq: initscripts >= 5.20
81%endif 89%endif
82BuildPreReq: perl, openssl-devel, tcp_wrappers 90BuildPreReq: perl, openssl-devel, sharutils, tcp_wrappers
83BuildPreReq: /bin/login 91BuildPreReq: /bin/login
84%if ! %{build6x} 92%if ! %{build6x}
85BuildPreReq: glibc-devel, pam 93BuildPreReq: glibc-devel, pam
86%else 94%else
87BuildPreReq: /usr/include/security/pam_appl.h 95BuildPreReq: db1-devel, /usr/include/security/pam_appl.h
88%endif 96%endif
89%if ! %{no_x11_askpass} 97%if ! %{no_x11_askpass}
90BuildPreReq: XFree86-devel 98BuildPreReq: XFree86-devel
@@ -188,6 +196,9 @@ CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
188%if %{scard} 196%if %{scard}
189 --with-smartcard \ 197 --with-smartcard \
190%endif 198%endif
199%if %{noip6}
200 --with-ipv4-default \
201%endif
191%if %{rescue} 202%if %{rescue}
192 --without-pam --with-md5-passwords \ 203 --without-pam --with-md5-passwords \
193%else 204%else
@@ -263,11 +274,9 @@ install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome
263 rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin 274 rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin
264%endif 275%endif
265 276
266%if ! %{no_gnome_askpass}
267install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/ 277install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
268install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/ 278install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
269install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/ 279install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
270%endif
271 280
272perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/* 281perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
273 282
@@ -391,14 +400,6 @@ fi
391%endif 400%endif
392 401
393%changelog 402%changelog
394* Mon Jun 2 2003 Damien Miller <djm@mindrot.org>
395- Remove noip6 option. This may be controlled at run-time in client config
396 file using new AddressFamily directive
397
398* Mon May 12 2003 Damien Miller <djm@mindrot.org>
399- Don't install profile.d scripts when not building with GNOME/GTK askpass
400 (patch from bet@rahul.net)
401
402* Wed Oct 01 2002 Damien Miller <djm@mindrot.org> 403* Wed Oct 01 2002 Damien Miller <djm@mindrot.org>
403- Install ssh-agent setgid nobody to prevent ptrace() key theft attacks 404- Install ssh-agent setgid nobody to prevent ptrace() key theft attacks
404 405