summaryrefslogtreecommitdiff
path: root/contrib/redhat/openssh.spec
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/redhat/openssh.spec')
-rw-r--r--contrib/redhat/openssh.spec27
1 files changed, 13 insertions, 14 deletions
diff --git a/contrib/redhat/openssh.spec b/contrib/redhat/openssh.spec
index e7c3bb121..ce7c564c3 100644
--- a/contrib/redhat/openssh.spec
+++ b/contrib/redhat/openssh.spec
@@ -1,4 +1,4 @@
1%define ver 3.6.1p2 1%define ver 3.7p1
2%define rel 1 2%define rel 1
3 3
4# OpenSSH privilege separation requires a user & group ID 4# OpenSSH privilege separation requires a user & group ID
@@ -26,9 +26,6 @@
26# Is this build for RHL 6.x? 26# Is this build for RHL 6.x?
27%define build6x 0 27%define build6x 0
28 28
29# Disable IPv6 (avoids DNS hangs on some glibc versions)
30%define noip6 0
31
32# Do we want kerberos5 support (1=yes 0=no) 29# Do we want kerberos5 support (1=yes 0=no)
33%define kerberos5 1 30%define kerberos5 1
34 31
@@ -43,7 +40,6 @@
43# If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc. 40# If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
44%if %{build6x} 41%if %{build6x}
45%define _sysconfdir /etc 42%define _sysconfdir /etc
46%define noip6 1
47%endif 43%endif
48 44
49# Options for static OpenSSL link: 45# Options for static OpenSSL link:
@@ -54,10 +50,6 @@
54# rpm -ba|--rebuild --define "smartcard 1" 50# rpm -ba|--rebuild --define "smartcard 1"
55%{?smartcard:%define scard 1} 51%{?smartcard:%define scard 1}
56 52
57# Option to disable ipv6
58# rpm -ba|--rebuild --define "noipv6 1"
59%{?noipv6:%define noip6 1}
60
61# Is this a build for the rescue CD (without PAM, with MD5)? (1=yes 0=no) 53# Is this a build for the rescue CD (without PAM, with MD5)? (1=yes 0=no)
62%define rescue 0 54%define rescue 0
63%{?build_rescue:%define rescue 1} 55%{?build_rescue:%define rescue 1}
@@ -87,12 +79,12 @@ PreReq: initscripts >= 5.00
87%else 79%else
88PreReq: initscripts >= 5.20 80PreReq: initscripts >= 5.20
89%endif 81%endif
90BuildPreReq: perl, openssl-devel, sharutils, tcp_wrappers 82BuildPreReq: perl, openssl-devel, tcp_wrappers
91BuildPreReq: /bin/login 83BuildPreReq: /bin/login
92%if ! %{build6x} 84%if ! %{build6x}
93BuildPreReq: glibc-devel, pam 85BuildPreReq: glibc-devel, pam
94%else 86%else
95BuildPreReq: db1-devel, /usr/include/security/pam_appl.h 87BuildPreReq: /usr/include/security/pam_appl.h
96%endif 88%endif
97%if ! %{no_x11_askpass} 89%if ! %{no_x11_askpass}
98BuildPreReq: XFree86-devel 90BuildPreReq: XFree86-devel
@@ -196,9 +188,6 @@ CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
196%if %{scard} 188%if %{scard}
197 --with-smartcard \ 189 --with-smartcard \
198%endif 190%endif
199%if %{noip6}
200 --with-ipv4-default \
201%endif
202%if %{rescue} 191%if %{rescue}
203 --without-pam --with-md5-passwords \ 192 --without-pam --with-md5-passwords \
204%else 193%else
@@ -274,9 +263,11 @@ install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome
274 rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin 263 rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin
275%endif 264%endif
276 265
266%if ! %{no_gnome_askpass}
277install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/ 267install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
278install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/ 268install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
279install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/ 269install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
270%endif
280 271
281perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/* 272perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
282 273
@@ -400,6 +391,14 @@ fi
400%endif 391%endif
401 392
402%changelog 393%changelog
394* Mon Jun 2 2003 Damien Miller <djm@mindrot.org>
395- Remove noip6 option. This may be controlled at run-time in client config
396 file using new AddressFamily directive
397
398* Mon May 12 2003 Damien Miller <djm@mindrot.org>
399- Don't install profile.d scripts when not building with GNOME/GTK askpass
400 (patch from bet@rahul.net)
401
403* Wed Oct 01 2002 Damien Miller <djm@mindrot.org> 402* Wed Oct 01 2002 Damien Miller <djm@mindrot.org>
404- Install ssh-agent setgid nobody to prevent ptrace() key theft attacks 403- Install ssh-agent setgid nobody to prevent ptrace() key theft attacks
405 404