summaryrefslogtreecommitdiff
path: root/debian/patches/consolekit.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/consolekit.patch')
-rw-r--r--debian/patches/consolekit.patch20
1 files changed, 10 insertions, 10 deletions
diff --git a/debian/patches/consolekit.patch b/debian/patches/consolekit.patch
index 0438b8f74..5ab47c0ca 100644
--- a/debian/patches/consolekit.patch
+++ b/debian/patches/consolekit.patch
@@ -1,4 +1,4 @@
1From 8b3111d597316954caaf8ddf2e7746491976c248 Mon Sep 17 00:00:00 2001 1From 1197fd975ab8fd11b1ac83557ef750129b16c0d8 Mon Sep 17 00:00:00 2001
2From: Colin Watson <cjwatson@ubuntu.com> 2From: Colin Watson <cjwatson@ubuntu.com>
3Date: Sun, 9 Feb 2014 16:09:57 +0000 3Date: Sun, 9 Feb 2014 16:09:57 +0000
4Subject: Add support for registering ConsoleKit sessions on login 4Subject: Add support for registering ConsoleKit sessions on login
@@ -37,10 +37,10 @@ index 3d2a328..c406aec 100644
37 MANPAGES = moduli.5.out scp.1.out ssh-add.1.out ssh-agent.1.out ssh-keygen.1.out ssh-keyscan.1.out ssh.1.out sshd.8.out sftp-server.8.out sftp.1.out ssh-keysign.8.out ssh-pkcs11-helper.8.out sshd_config.5.out ssh_config.5.out 37 MANPAGES = moduli.5.out scp.1.out ssh-add.1.out ssh-agent.1.out ssh-keygen.1.out ssh-keyscan.1.out ssh.1.out sshd.8.out sftp-server.8.out sftp.1.out ssh-keysign.8.out ssh-pkcs11-helper.8.out sshd_config.5.out ssh_config.5.out
38 MANPAGES_IN = moduli.5 scp.1 ssh-add.1 ssh-agent.1 ssh-keygen.1 ssh-keyscan.1 ssh.1 sshd.8 sftp-server.8 sftp.1 ssh-keysign.8 ssh-pkcs11-helper.8 sshd_config.5 ssh_config.5 38 MANPAGES_IN = moduli.5 scp.1 ssh-add.1 ssh-agent.1 ssh-keygen.1 ssh-keyscan.1 ssh.1 sshd.8 sftp-server.8 sftp.1 ssh-keysign.8 ssh-pkcs11-helper.8 sshd_config.5 ssh_config.5
39diff --git a/configure.ac b/configure.ac 39diff --git a/configure.ac b/configure.ac
40index 5f606ea..f7ce777 100644 40index 4d55c46..cd6acaf 100644
41--- a/configure.ac 41--- a/configure.ac
42+++ b/configure.ac 42+++ b/configure.ac
43@@ -4180,6 +4180,30 @@ AC_ARG_WITH([kerberos5], 43@@ -4188,6 +4188,30 @@ AC_ARG_WITH([kerberos5],
44 AC_SUBST([GSSLIBS]) 44 AC_SUBST([GSSLIBS])
45 AC_SUBST([K5LIBS]) 45 AC_SUBST([K5LIBS])
46 46
@@ -71,7 +71,7 @@ index 5f606ea..f7ce777 100644
71 # Looking for programs, paths and files 71 # Looking for programs, paths and files
72 72
73 PRIVSEP_PATH=/var/empty 73 PRIVSEP_PATH=/var/empty
74@@ -4981,6 +5005,7 @@ echo " MD5 password support: $MD5_MSG" 74@@ -4989,6 +5013,7 @@ echo " MD5 password support: $MD5_MSG"
75 echo " libedit support: $LIBEDIT_MSG" 75 echo " libedit support: $LIBEDIT_MSG"
76 echo " Solaris process contract support: $SPC_MSG" 76 echo " Solaris process contract support: $SPC_MSG"
77 echo " Solaris project support: $SP_MSG" 77 echo " Solaris project support: $SP_MSG"
@@ -357,7 +357,7 @@ index 0000000..8ce3716
357+ 357+
358+#endif /* USE_CONSOLEKIT */ 358+#endif /* USE_CONSOLEKIT */
359diff --git a/monitor.c b/monitor.c 359diff --git a/monitor.c b/monitor.c
360index 6ff05e4..ce7ba07 100644 360index 3a3d2f0..12ed6fd 100644
361--- a/monitor.c 361--- a/monitor.c
362+++ b/monitor.c 362+++ b/monitor.c
363@@ -104,6 +104,9 @@ 363@@ -104,6 +104,9 @@
@@ -411,7 +411,7 @@ index 6ff05e4..ce7ba07 100644
411 411
412 for (;;) 412 for (;;)
413 monitor_read(pmonitor, mon_dispatch, NULL); 413 monitor_read(pmonitor, mon_dispatch, NULL);
414@@ -2187,3 +2203,29 @@ mm_answer_gss_updatecreds(int socket, Buffer *m) { 414@@ -2191,3 +2207,29 @@ mm_answer_gss_updatecreds(int socket, Buffer *m) {
415 415
416 #endif /* GSSAPI */ 416 #endif /* GSSAPI */
417 417
@@ -455,10 +455,10 @@ index 2d82b8b..fd8d92c 100644
455 455
456 struct mm_master; 456 struct mm_master;
457diff --git a/monitor_wrap.c b/monitor_wrap.c 457diff --git a/monitor_wrap.c b/monitor_wrap.c
458index 5aa9c47..a5f4e9d 100644 458index 6ae72a0..2a0fe9b 100644
459--- a/monitor_wrap.c 459--- a/monitor_wrap.c
460+++ b/monitor_wrap.c 460+++ b/monitor_wrap.c
461@@ -1150,3 +1150,33 @@ mm_ssh_gssapi_update_creds(ssh_gssapi_ccache *store) 461@@ -1151,3 +1151,33 @@ mm_ssh_gssapi_update_creds(ssh_gssapi_ccache *store)
462 462
463 #endif /* GSSAPI */ 463 #endif /* GSSAPI */
464 464
@@ -493,7 +493,7 @@ index 5aa9c47..a5f4e9d 100644
493+} 493+}
494+#endif /* USE_CONSOLEKIT */ 494+#endif /* USE_CONSOLEKIT */
495diff --git a/monitor_wrap.h b/monitor_wrap.h 495diff --git a/monitor_wrap.h b/monitor_wrap.h
496index 4d1e899..f99c31c 100644 496index 57e740f..6829392 100644
497--- a/monitor_wrap.h 497--- a/monitor_wrap.h
498+++ b/monitor_wrap.h 498+++ b/monitor_wrap.h
499@@ -108,4 +108,8 @@ int mm_skey_respond(void *, u_int, char **); 499@@ -108,4 +108,8 @@ int mm_skey_respond(void *, u_int, char **);
@@ -506,7 +506,7 @@ index 4d1e899..f99c31c 100644
506+ 506+
507 #endif /* _MM_WRAP_H_ */ 507 #endif /* _MM_WRAP_H_ */
508diff --git a/session.c b/session.c 508diff --git a/session.c b/session.c
509index d4b7725..785833f 100644 509index afac4a5..c6bd728 100644
510--- a/session.c 510--- a/session.c
511+++ b/session.c 511+++ b/session.c
512@@ -94,6 +94,7 @@ 512@@ -94,6 +94,7 @@