summaryrefslogtreecommitdiff
path: root/debian/patches/lintian-symlink-pickiness.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/lintian-symlink-pickiness.patch')
-rw-r--r--debian/patches/lintian-symlink-pickiness.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/patches/lintian-symlink-pickiness.patch b/debian/patches/lintian-symlink-pickiness.patch
new file mode 100644
index 000000000..3afddb70e
--- /dev/null
+++ b/debian/patches/lintian-symlink-pickiness.patch
@@ -0,0 +1,21 @@
1Description: Fix picky lintian errors about slogin symlinks
2Author: Colin Watson <cjwatson@debian.org>
3Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1728
4Last-Update: 2010-03-01
5
6Index: b/Makefile.in
7===================================================================
8--- a/Makefile.in
9+++ b/Makefile.in
10@@ -295,9 +295,9 @@
11 $(INSTALL) -m 644 ssh-pkcs11-helper.8.out $(DESTDIR)$(mandir)/$(mansubdir)8/ssh-pkcs11-helper.8
12 $(INSTALL) -m 644 ssh-vulnkey.1.out $(DESTDIR)$(mandir)/$(mansubdir)1/ssh-vulnkey.1
13 -rm -f $(DESTDIR)$(bindir)/slogin
14- ln -s ./ssh$(EXEEXT) $(DESTDIR)$(bindir)/slogin
15+ ln -s ssh$(EXEEXT) $(DESTDIR)$(bindir)/slogin
16 -rm -f $(DESTDIR)$(mandir)/$(mansubdir)1/slogin.1
17- ln -s ./ssh.1 $(DESTDIR)$(mandir)/$(mansubdir)1/slogin.1
18+ ln -s ssh.1 $(DESTDIR)$(mandir)/$(mansubdir)1/slogin.1
19
20 install-sysconf:
21 if [ ! -d $(DESTDIR)$(sysconfdir) ]; then \