summaryrefslogtreecommitdiff
path: root/debian/patches/selinux-autoconf.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/selinux-autoconf.patch')
-rw-r--r--debian/patches/selinux-autoconf.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/debian/patches/selinux-autoconf.patch b/debian/patches/selinux-autoconf.patch
new file mode 100644
index 000000000..934f885c8
--- /dev/null
+++ b/debian/patches/selinux-autoconf.patch
@@ -0,0 +1,33 @@
1Index: b/configure
2===================================================================
3--- a/configure
4+++ b/configure
5@@ -28011,6 +28011,8 @@
6 $as_echo "$ac_cv_lib_selinux_setexeccon" >&6; }
7 if test $ac_cv_lib_selinux_setexeccon = yes; then
8 LIBSELINUX="-lselinux"
9+ LIBS="$LIBS -lselinux"
10+
11 else
12 { { $as_echo "$as_me:$LINENO: error: SELinux support requires libselinux library" >&5
13 $as_echo "$as_me: error: SELinux support requires libselinux library" >&2;}
14Index: b/configure.ac
15===================================================================
16--- a/configure.ac
17+++ b/configure.ac
18@@ -3422,9 +3422,12 @@
19 AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.])
20 SELINUX_MSG="yes"
21 AC_CHECK_HEADER([selinux/selinux.h], ,
22- AC_MSG_ERROR(SELinux support requires selinux.h header))
23- AC_CHECK_LIB(selinux, setexeccon, [ LIBSELINUX="-lselinux" ],
24- AC_MSG_ERROR(SELinux support requires libselinux library))
25+ AC_MSG_ERROR(SELinux support requires selinux.h header))
26+ AC_CHECK_LIB(selinux, setexeccon,
27+ [ LIBSELINUX="-lselinux"
28+ LIBS="$LIBS -lselinux"
29+ ],
30+ AC_MSG_ERROR(SELinux support requires libselinux library))
31 SSHDLIBS="$SSHDLIBS $LIBSELINUX"
32 AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level)
33 LIBS="$save_LIBS"