summaryrefslogtreecommitdiff
path: root/debian/patches/selinux-autoconf.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/selinux-autoconf.patch')
-rw-r--r--debian/patches/selinux-autoconf.patch46
1 files changed, 0 insertions, 46 deletions
diff --git a/debian/patches/selinux-autoconf.patch b/debian/patches/selinux-autoconf.patch
deleted file mode 100644
index 9ac4cd435..000000000
--- a/debian/patches/selinux-autoconf.patch
+++ /dev/null
@@ -1,46 +0,0 @@
1Description: Fix seusers detection at configure time
2 configure didn't add -lselinux to LIBS before it checked for the existence
3 of getseuserbyname and get_default_context_with_level. This resulted in
4 seusers configuration not being handled correctly. Most policies use the
5 seusers feature, and without it login security contexts will not be
6 correct.
7Author: Caleb Case <calebcase@gmail.com>
8Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1713
9Bug-Debian: http://bugs.debian.org/465614
10Bug-Ubuntu: https://bugs.launchpad.net/bugs/188136
11Reviewed-by: Colin Watson <cjwatson@debian.org>
12Last-Update: 2010-02-27
13
14Index: b/configure
15===================================================================
16--- a/configure
17+++ b/configure
18@@ -28011,6 +28011,8 @@
19 $as_echo "$ac_cv_lib_selinux_setexeccon" >&6; }
20 if test $ac_cv_lib_selinux_setexeccon = yes; then
21 LIBSELINUX="-lselinux"
22+ LIBS="$LIBS -lselinux"
23+
24 else
25 { { $as_echo "$as_me:$LINENO: error: SELinux support requires libselinux library" >&5
26 $as_echo "$as_me: error: SELinux support requires libselinux library" >&2;}
27Index: b/configure.ac
28===================================================================
29--- a/configure.ac
30+++ b/configure.ac
31@@ -3422,9 +3422,12 @@
32 AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.])
33 SELINUX_MSG="yes"
34 AC_CHECK_HEADER([selinux/selinux.h], ,
35- AC_MSG_ERROR(SELinux support requires selinux.h header))
36- AC_CHECK_LIB(selinux, setexeccon, [ LIBSELINUX="-lselinux" ],
37- AC_MSG_ERROR(SELinux support requires libselinux library))
38+ AC_MSG_ERROR(SELinux support requires selinux.h header))
39+ AC_CHECK_LIB(selinux, setexeccon,
40+ [ LIBSELINUX="-lselinux"
41+ LIBS="$LIBS -lselinux"
42+ ],
43+ AC_MSG_ERROR(SELinux support requires libselinux library))
44 SSHDLIBS="$SSHDLIBS $LIBSELINUX"
45 AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level)
46 LIBS="$save_LIBS"