diff options
Diffstat (limited to 'debian/rules')
-rwxr-xr-x | debian/rules | 250 |
1 files changed, 250 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules new file mode 100755 index 000000000..01937b39e --- /dev/null +++ b/debian/rules | |||
@@ -0,0 +1,250 @@ | |||
1 | #!/usr/bin/make -f | ||
2 | |||
3 | # Uncomment this to turn on verbose mode. | ||
4 | # export DH_VERBOSE=1 | ||
5 | |||
6 | # This has to be exported to make some magic below work. | ||
7 | export DH_OPTIONS | ||
8 | |||
9 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) | ||
10 | RUN_TESTS := yes | ||
11 | else | ||
12 | RUN_TESTS := | ||
13 | endif | ||
14 | |||
15 | ifeq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS))) | ||
16 | PARALLEL := | ||
17 | else | ||
18 | PARALLEL := \ | ||
19 | -j$(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))) | ||
20 | endif | ||
21 | |||
22 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) | ||
23 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) | ||
24 | DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH) | ||
25 | |||
26 | ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE)) | ||
27 | CC := gcc | ||
28 | PKG_CONFIG = pkg-config | ||
29 | else | ||
30 | CC := $(DEB_HOST_GNU_TYPE)-gcc | ||
31 | PKG_CONFIG = $(DEB_HOST_GNU_TYPE)-pkg-config | ||
32 | RUN_TESTS := | ||
33 | endif | ||
34 | |||
35 | DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null) | ||
36 | |||
37 | # Take account of old dpkg-architecture output. | ||
38 | ifeq ($(DEB_HOST_ARCH_OS),) | ||
39 | DEB_HOST_ARCH_OS := $(subst -gnu,,$(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)) | ||
40 | ifeq ($(DEB_HOST_ARCH_OS),gnu) | ||
41 | DEB_HOST_ARCH_OS := hurd | ||
42 | endif | ||
43 | endif | ||
44 | |||
45 | # Change the version string to reflect distribution | ||
46 | DISTRIBUTION := $(shell dpkg-vendor --query vendor) | ||
47 | SSH_EXTRAVERSION := $(DISTRIBUTION)-$(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p' | sed -e 's/[^-]*-//') | ||
48 | |||
49 | DISTRIBUTOR := $(shell if dpkg-vendor --derives-from Ubuntu 2>/dev/null; then echo Ubuntu; else echo Debian; fi) | ||
50 | ifeq ($(DISTRIBUTOR),Ubuntu) | ||
51 | DEFAULT_PATH := /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games | ||
52 | else | ||
53 | DEFAULT_PATH := /usr/local/bin:/usr/bin:/bin:/usr/games | ||
54 | endif | ||
55 | SUPERUSER_PATH := /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin | ||
56 | |||
57 | ifeq ($(DISTRIBUTOR),Ubuntu) | ||
58 | server_recommends := ssh-import-id | ||
59 | else | ||
60 | server_recommends := | ||
61 | endif | ||
62 | |||
63 | # Common path configuration. | ||
64 | confflags += --sysconfdir=/etc/ssh | ||
65 | confflags += --libexecdir=\$${prefix}/lib/openssh | ||
66 | |||
67 | # Common build options. | ||
68 | confflags += --disable-strip | ||
69 | confflags += --with-mantype=doc | ||
70 | confflags += --with-4in6 | ||
71 | confflags += --with-privsep-path=/var/run/sshd | ||
72 | |||
73 | # The Hurd needs libcrypt for res_query et al. | ||
74 | ifeq ($(DEB_HOST_ARCH_OS),hurd) | ||
75 | confflags += --with-libs=-lcrypt | ||
76 | endif | ||
77 | |||
78 | # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=60155 | ||
79 | ifeq ($(DEB_HOST_ARCH),hppa) | ||
80 | confflags += --without-hardening | ||
81 | endif | ||
82 | |||
83 | # Everything above here is common to the deb and udeb builds. | ||
84 | confflags_udeb := $(confflags) | ||
85 | |||
86 | # Options specific to the deb build. | ||
87 | confflags += --with-tcp-wrappers | ||
88 | confflags += --with-pam | ||
89 | confflags += --with-libedit | ||
90 | confflags += --with-kerberos5=/usr | ||
91 | confflags += --with-ssl-engine | ||
92 | ifeq ($(DEB_HOST_ARCH_OS),linux) | ||
93 | confflags += --with-selinux | ||
94 | confflags += --with-audit=linux | ||
95 | confflags += --with-systemd | ||
96 | endif | ||
97 | |||
98 | # The deb build wants xauth; the udeb build doesn't. | ||
99 | confflags += --with-xauth=/usr/bin/xauth | ||
100 | confflags_udeb += --without-xauth | ||
101 | |||
102 | # Default paths. The udeb build has /usr/games removed. | ||
103 | confflags += --with-default-path=$(DEFAULT_PATH) --with-superuser-path=$(SUPERUSER_PATH) | ||
104 | confflags_udeb += --with-default-path=/usr/local/bin:/usr/bin:/bin --with-superuser-path=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin | ||
105 | |||
106 | # Compiler flags. | ||
107 | export DEB_BUILD_MAINT_OPTIONS := hardening=+all | ||
108 | include /usr/share/dpkg/buildflags.mk | ||
109 | cflags := $(CPPFLAGS) $(CFLAGS) | ||
110 | cflags += -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT | ||
111 | cflags += -DSSH_EXTRAVERSION=\"$(SSH_EXTRAVERSION)\" | ||
112 | cflags_udeb := -Os | ||
113 | cflags_udeb += -DSSH_EXTRAVERSION=\"$(SSH_EXTRAVERSION)\" | ||
114 | confflags += --with-cflags='$(cflags)' | ||
115 | confflags_udeb += --with-cflags='$(cflags_udeb)' | ||
116 | |||
117 | # Linker flags. | ||
118 | confflags += --with-ldflags='$(strip -Wl,--as-needed $(LDFLAGS))' | ||
119 | confflags_udeb += --with-ldflags='-Wl,--as-needed' | ||
120 | |||
121 | %: | ||
122 | dh $@ --with=autoreconf,systemd | ||
123 | |||
124 | autoreconf: | ||
125 | autoreconf -f -i | ||
126 | cp -f /usr/share/misc/config.guess /usr/share/misc/config.sub ./ | ||
127 | |||
128 | override_dh_autoreconf-arch: | ||
129 | dh_autoreconf debian/rules -- autoreconf | ||
130 | |||
131 | override_dh_autoreconf-indep: | ||
132 | |||
133 | override_dh_auto_configure-arch: | ||
134 | dh_auto_configure -Bbuild-deb -- $(confflags) | ||
135 | dh_auto_configure -Bbuild-deb-ssh1 -- $(confflags) --with-ssh1 | ||
136 | dh_auto_configure -Bbuild-udeb -- $(confflags_udeb) | ||
137 | |||
138 | override_dh_auto_configure-indep: | ||
139 | |||
140 | override_dh_auto_build-arch: | ||
141 | # Avoid libnsl linkage. Ugh. | ||
142 | perl -pi -e 's/ +-lnsl//' build-udeb/config.status | ||
143 | cd build-udeb && ./config.status | ||
144 | |||
145 | $(MAKE) -C build-deb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass' | ||
146 | $(MAKE) -C build-deb-ssh1 $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass' ssh scp ssh-keygen | ||
147 | $(MAKE) -C build-udeb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass' ssh scp sftp sshd ssh-keygen | ||
148 | |||
149 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='$(CC) $(CPPFLAGS) $(CFLAGS) -Wall -Wl,--as-needed $(LDFLAGS)' PKG_CONFIG=$(PKG_CONFIG) | ||
150 | |||
151 | override_dh_auto_build-indep: | ||
152 | |||
153 | override_dh_auto_test-arch: | ||
154 | ifeq ($(RUN_TESTS),yes) | ||
155 | $(MAKE) -C build-deb regress-prep | ||
156 | $(MAKE) -C build-deb $(PARALLEL) \ | ||
157 | regress/unittests/sshbuf/test_sshbuf \ | ||
158 | regress/unittests/sshkey/test_sshkey \ | ||
159 | regress/unittests/bitmap/test_bitmap \ | ||
160 | regress/unittests/hostkeys/test_hostkeys \ | ||
161 | regress/unittests/kex/test_kex | ||
162 | $(MAKE) -C build-deb/regress \ | ||
163 | .OBJDIR="$(CURDIR)/build-deb/regress" \ | ||
164 | .CURDIR="$(CURDIR)/regress" \ | ||
165 | unit | ||
166 | $(MAKE) -C build-deb compat-tests | ||
167 | $(MAKE) -C debian/keygen-test | ||
168 | endif | ||
169 | |||
170 | override_dh_auto_test-indep: | ||
171 | |||
172 | override_dh_auto_clean: | ||
173 | rm -rf build-deb build-deb-ssh1 build-udeb | ||
174 | ifeq ($(RUN_TESTS),yes) | ||
175 | $(MAKE) -C debian/keygen-test clean | ||
176 | endif | ||
177 | $(MAKE) -C contrib clean | ||
178 | (cat debian/copyright.head; iconv -f ISO-8859-1 -t UTF-8 LICENCE) \ | ||
179 | > debian/copyright | ||
180 | |||
181 | override_dh_auto_install-arch: | ||
182 | $(MAKE) -C build-deb DESTDIR=`pwd`/debian/tmp install-nokeys | ||
183 | |||
184 | override_dh_auto_install-indep: | ||
185 | |||
186 | override_dh_install-arch: | ||
187 | rm -f debian/tmp/etc/ssh/sshd_config | ||
188 | |||
189 | dh_install -Nopenssh-client-udeb -Nopenssh-server-udeb --fail-missing | ||
190 | dh_install -popenssh-client-udeb -popenssh-server-udeb \ | ||
191 | --sourcedir=build-udeb | ||
192 | |||
193 | # Remove version control tags to avoid unnecessary conffile | ||
194 | # resolution steps for administrators. | ||
195 | sed -i '/\$$OpenBSD:/d' \ | ||
196 | debian/openssh-client/etc/ssh/moduli \ | ||
197 | debian/openssh-client/etc/ssh/ssh_config | ||
198 | |||
199 | # We'd like to use dh_install --fail-missing here, but that doesn't work | ||
200 | # well in combination with dh-exec: it complains that files generated by | ||
201 | # dh-exec for architecture-dependent packages aren't installed. | ||
202 | override_dh_install-indep: | ||
203 | rm -f debian/tmp/etc/ssh/sshd_config | ||
204 | dh_install | ||
205 | |||
206 | override_dh_installdocs: | ||
207 | dh_installdocs \ | ||
208 | -Nopenssh-client-ssh1 -Nopenssh-server -Nopenssh-sftp-server | ||
209 | dh_installdocs \ | ||
210 | -popenssh-client-ssh1 -popenssh-server -popenssh-sftp-server \ | ||
211 | --link-doc=openssh-client | ||
212 | # Avoid breaking dh_installexamples later. | ||
213 | mkdir -p debian/openssh-server/usr/share/doc/openssh-client | ||
214 | |||
215 | override_dh_systemd_enable: | ||
216 | dh_systemd_enable -popenssh-server --name ssh ssh.service | ||
217 | dh_systemd_enable -popenssh-server --name ssh --no-enable ssh.socket | ||
218 | |||
219 | override_dh_installinit: | ||
220 | dh_installinit -R --name ssh | ||
221 | |||
222 | debian/openssh-server.sshd.pam: debian/openssh-server.sshd.pam.in | ||
223 | ifeq ($(DEB_HOST_ARCH_OS),linux) | ||
224 | sed 's/^@IF_KEYINIT@//' $< > $@ | ||
225 | else | ||
226 | sed '/^@IF_KEYINIT@/d' $< > $@ | ||
227 | endif | ||
228 | |||
229 | override_dh_installpam: debian/openssh-server.sshd.pam | ||
230 | dh_installpam --name sshd | ||
231 | |||
232 | override_dh_fixperms-arch: | ||
233 | dh_fixperms | ||
234 | chmod u+s debian/openssh-client/usr/lib/openssh/ssh-keysign | ||
235 | |||
236 | # Tighten libssl dependencies to match the check in entropy.c. | ||
237 | override_dh_shlibdeps: | ||
238 | dh_shlibdeps | ||
239 | debian/adjust-openssl-dependencies | ||
240 | |||
241 | override_dh_gencontrol: | ||
242 | dh_gencontrol -- -V'openssh-server:Recommends=$(server_recommends)' | ||
243 | |||
244 | override_dh_builddeb: | ||
245 | dh_builddeb -- -Zxz | ||
246 | |||
247 | debian/faq.html: | ||
248 | wget -O - http://www.openssh.org/faq.html | \ | ||
249 | sed 's,\(href="\)\(txt/\|[^":]*\.html\),\1http://www.openssh.org/\2,g' \ | ||
250 | > debian/faq.html | ||