diff options
Diffstat (limited to 'debian/rules')
-rwxr-xr-x | debian/rules | 14 |
1 files changed, 7 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules index cbad70815..90bd7ba9e 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -58,12 +58,12 @@ build-deb: build-deb-stamp | |||
58 | build-deb-stamp: | 58 | build-deb-stamp: |
59 | dh_testdir | 59 | dh_testdir |
60 | mkdir -p build-deb | 60 | mkdir -p build-deb |
61 | cd build-deb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper --with-libedit | 61 | cd build-deb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib/openssh --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper --with-libedit |
62 | 62 | ||
63 | # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999). | 63 | # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999). |
64 | perl -pi -e 's/.*#undef (BROKEN_SETRES[UG]ID).*/#define $$1 1/' build-deb/config.h | 64 | perl -pi -e 's/.*#undef (BROKEN_SETRES[UG]ID).*/#define $$1 1/' build-deb/config.h |
65 | 65 | ||
66 | $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' | 66 | $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""' SSH_KEYSIGN='/usr/lib/openssh/ssh-keysign' |
67 | # Support building on Debian 3.0 (with GNOME 1.4) and later. | 67 | # Support building on Debian 3.0 (with GNOME 1.4) and later. |
68 | if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ | 68 | if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ |
69 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \ | 69 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \ |
@@ -77,11 +77,11 @@ build-udeb: build-udeb-stamp | |||
77 | build-udeb-stamp: | 77 | build-udeb-stamp: |
78 | dh_testdir | 78 | dh_testdir |
79 | mkdir -p build-udeb | 79 | mkdir -p build-udeb |
80 | cd build-udeb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --without-xauth --with-default-path=/usr/local/bin:/bin:/usr/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper | 80 | cd build-udeb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib/openssh --without-xauth --with-default-path=/usr/local/bin:/bin:/usr/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper |
81 | # Avoid libnsl linkage. Ugh. | 81 | # Avoid libnsl linkage. Ugh. |
82 | perl -pi -e 's/ +-lnsl//' build-udeb/config.status | 82 | perl -pi -e 's/ +-lnsl//' build-udeb/config.status |
83 | cd build-udeb && ./config.status | 83 | cd build-udeb && ./config.status |
84 | $(MAKE) -C build-udeb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-Os -g -Wall -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' ssh scp sftp sshd ssh-keygen | 84 | $(MAKE) -C build-udeb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-Os -g -Wall -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""' SSH_KEYSIGN='/usr/lib/openssh/ssh-keysign' ssh scp sftp sshd ssh-keygen |
85 | touch build-udeb-stamp | 85 | touch build-udeb-stamp |
86 | 86 | ||
87 | clean: | 87 | clean: |
@@ -125,7 +125,7 @@ install: build | |||
125 | 125 | ||
126 | # Split off the server. | 126 | # Split off the server. |
127 | mv debian/openssh-client/usr/sbin/sshd debian/openssh-server/usr/sbin/ | 127 | mv debian/openssh-client/usr/sbin/sshd debian/openssh-server/usr/sbin/ |
128 | mv debian/openssh-client/usr/lib/sftp-server debian/openssh-server/usr/lib/ | 128 | mv debian/openssh-client/usr/lib/openssh/sftp-server debian/openssh-server/usr/lib/openssh/ |
129 | mv debian/openssh-client/usr/share/man/man5/sshd_config.5 debian/openssh-server/usr/share/man/man5/ | 129 | mv debian/openssh-client/usr/share/man/man5/sshd_config.5 debian/openssh-server/usr/share/man/man5/ |
130 | mv debian/openssh-client/usr/share/man/man8/sshd.8 debian/openssh-server/usr/share/man/man8/ | 130 | mv debian/openssh-client/usr/share/man/man8/sshd.8 debian/openssh-server/usr/share/man/man8/ |
131 | mv debian/openssh-client/usr/share/man/man8/sftp-server.8 debian/openssh-server/usr/share/man/man8/ | 131 | mv debian/openssh-client/usr/share/man/man8/sftp-server.8 debian/openssh-server/usr/share/man/man8/ |
@@ -137,9 +137,9 @@ install: build | |||
137 | 137 | ||
138 | ifneq ($(DEB_HOST_ARCH_OS),gnu) | 138 | ifneq ($(DEB_HOST_ARCH_OS),gnu) |
139 | if [ -f contrib/gnome-ssh-askpass2 ]; then \ | 139 | if [ -f contrib/gnome-ssh-askpass2 ]; then \ |
140 | install -s -o root -g root -m 755 contrib/gnome-ssh-askpass2 debian/ssh-askpass-gnome/usr/lib/ssh/gnome-ssh-askpass; \ | 140 | install -s -o root -g root -m 755 contrib/gnome-ssh-askpass2 debian/ssh-askpass-gnome/usr/lib/openssh/gnome-ssh-askpass; \ |
141 | elif [ -f contrib/gnome-ssh-askpass1 ]; then \ | 141 | elif [ -f contrib/gnome-ssh-askpass1 ]; then \ |
142 | install -s -o root -g root -m 755 contrib/gnome-ssh-askpass1 debian/ssh-askpass-gnome/usr/lib/ssh/gnome-ssh-askpass; \ | 142 | install -s -o root -g root -m 755 contrib/gnome-ssh-askpass1 debian/ssh-askpass-gnome/usr/lib/openssh/gnome-ssh-askpass; \ |
143 | fi | 143 | fi |
144 | install -m 644 debian/gnome-ssh-askpass.1 debian/ssh-askpass-gnome/usr/share/man/man1/gnome-ssh-askpass.1 | 144 | install -m 644 debian/gnome-ssh-askpass.1 debian/ssh-askpass-gnome/usr/share/man/man1/gnome-ssh-askpass.1 |
145 | uudecode -o debian/ssh-askpass-gnome/usr/share/pixmaps/ssh-askpass-gnome.png debian/ssh-askpass-gnome.png.uue | 145 | uudecode -o debian/ssh-askpass-gnome/usr/share/pixmaps/ssh-askpass-gnome.png debian/ssh-askpass-gnome.png.uue |