diff options
Diffstat (limited to 'debian/rules')
-rwxr-xr-x | debian/rules | 11 |
1 files changed, 9 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules index 5a4e4cc59..9e1350568 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -14,6 +14,12 @@ else | |||
14 | OPTFLAGS := -O0 | 14 | OPTFLAGS := -O0 |
15 | endif | 15 | endif |
16 | 16 | ||
17 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) | ||
18 | RUN_TESTS := yes | ||
19 | else | ||
20 | RUN_TESTS := | ||
21 | endif | ||
22 | |||
17 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) | 23 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
18 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) | 24 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
19 | 25 | ||
@@ -23,6 +29,7 @@ ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE)) | |||
23 | else | 29 | else |
24 | confflags += --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) | 30 | confflags += --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
25 | CC := $(DEB_HOST_GNU_TYPE)-gcc | 31 | CC := $(DEB_HOST_GNU_TYPE)-gcc |
32 | RUN_TESTS := | ||
26 | endif | 33 | endif |
27 | 34 | ||
28 | DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null) | 35 | DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null) |
@@ -123,7 +130,7 @@ build-deb-stamp: | |||
123 | 130 | ||
124 | $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' | 131 | $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' |
125 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='$(CC) $(OPTFLAGS) -g -Wall -Wl,--as-needed' | 132 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='$(CC) $(OPTFLAGS) -g -Wall -Wl,--as-needed' |
126 | ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE)) | 133 | ifeq ($(RUN_TESTS),yes) |
127 | $(MAKE) -C debian/tests | 134 | $(MAKE) -C debian/tests |
128 | endif | 135 | endif |
129 | 136 | ||
@@ -145,7 +152,7 @@ build-udeb-stamp: | |||
145 | clean: | 152 | clean: |
146 | dh_testdir | 153 | dh_testdir |
147 | rm -rf build-deb build-udeb | 154 | rm -rf build-deb build-udeb |
148 | ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE)) | 155 | ifeq ($(RUN_TESTS),yes) |
149 | $(MAKE) -C debian/tests clean | 156 | $(MAKE) -C debian/tests clean |
150 | endif | 157 | endif |
151 | $(MAKE) -C contrib clean | 158 | $(MAKE) -C contrib clean |