diff options
Diffstat (limited to 'debian/rules')
-rwxr-xr-x | debian/rules | 19 |
1 files changed, 17 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules index 1ce189b6a..4404c28dd 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -166,7 +166,7 @@ install: build | |||
166 | install -m 755 build-udeb/ssh-keygen debian/openssh-server-udeb/usr/bin/ssh-keygen | 166 | install -m 755 build-udeb/ssh-keygen debian/openssh-server-udeb/usr/bin/ssh-keygen |
167 | 167 | ||
168 | # Build architecture-independent files here. | 168 | # Build architecture-independent files here. |
169 | binary-indep: binary-ssh | 169 | binary-indep: binary-ssh binary-ssh-krb5 |
170 | 170 | ||
171 | # Build architecture-dependent files here. | 171 | # Build architecture-dependent files here. |
172 | binary-arch: binary-openssh-client binary-openssh-server | 172 | binary-arch: binary-openssh-client binary-openssh-server |
@@ -244,6 +244,21 @@ binary-ssh: build install | |||
244 | dh_md5sums | 244 | dh_md5sums |
245 | dh_builddeb | 245 | dh_builddeb |
246 | 246 | ||
247 | binary-ssh-krb5: DH_OPTIONS=-pssh-krb5 | ||
248 | binary-ssh-krb5: build install | ||
249 | dh_testdir | ||
250 | dh_testroot | ||
251 | dh_installdocs | ||
252 | mv debian/ssh-krb5/usr/share/doc/ssh-krb5 debian/ssh-krb5/usr/share/doc/openssh-client | ||
253 | rm -f debian/ssh-krb5/usr/share/doc/openssh-client/copyright | ||
254 | dh_link | ||
255 | dh_compress | ||
256 | dh_fixperms | ||
257 | dh_installdeb | ||
258 | dh_gencontrol | ||
259 | dh_md5sums | ||
260 | dh_builddeb | ||
261 | |||
247 | binary-ssh-askpass-gnome: DH_OPTIONS=-pssh-askpass-gnome | 262 | binary-ssh-askpass-gnome: DH_OPTIONS=-pssh-askpass-gnome |
248 | binary-ssh-askpass-gnome: build install | 263 | binary-ssh-askpass-gnome: build install |
249 | dh_testdir | 264 | dh_testdir |
@@ -292,5 +307,5 @@ binary: binary-indep binary-arch | |||
292 | .PHONY: build clean binary-indep binary-arch binary install | 307 | .PHONY: build clean binary-indep binary-arch binary install |
293 | .PHONY: build-deb build-udeb | 308 | .PHONY: build-deb build-udeb |
294 | .PHONY: binary-openssh-client binary-openssh-server binary-ssh | 309 | .PHONY: binary-openssh-client binary-openssh-server binary-ssh |
295 | .PHONY: binary-ssh-askpass-gnome | 310 | .PHONY: binary-ssh-krb5 binary-ssh-askpass-gnome |
296 | .PHONY: binary-openssh-client-udeb binary-openssh-server-udeb | 311 | .PHONY: binary-openssh-client-udeb binary-openssh-server-udeb |