summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules239
1 files changed, 239 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 000000000..9201dbd5a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,239 @@
1#!/usr/bin/make -f
2
3# Uncomment this to turn on verbose mode.
4# export DH_VERBOSE=1
5
6# This has to be exported to make some magic below work.
7export DH_OPTIONS
8
9ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
10 RUN_TESTS := yes
11else
12 RUN_TESTS :=
13endif
14
15ifeq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
16 PARALLEL :=
17else
18 PARALLEL := \
19 -j$(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
20endif
21
22DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
23DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
24DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
25
26ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
27 CC := gcc
28 PKG_CONFIG = pkg-config
29else
30 CC := $(DEB_HOST_GNU_TYPE)-gcc
31 PKG_CONFIG = $(DEB_HOST_GNU_TYPE)-pkg-config
32 RUN_TESTS :=
33endif
34
35DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null)
36
37# Take account of old dpkg-architecture output.
38ifeq ($(DEB_HOST_ARCH_OS),)
39 DEB_HOST_ARCH_OS := $(subst -gnu,,$(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM))
40 ifeq ($(DEB_HOST_ARCH_OS),gnu)
41 DEB_HOST_ARCH_OS := hurd
42 endif
43endif
44
45# Change the version string to reflect distribution
46DISTRIBUTION := $(shell dpkg-vendor --query vendor)
47SSH_EXTRAVERSION := $(DISTRIBUTION)-$(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p' | sed -e 's/[^-]*-//')
48
49DISTRIBUTOR := $(shell if dpkg-vendor --derives-from Ubuntu 2>/dev/null; then echo Ubuntu; else echo Debian; fi)
50ifeq ($(DISTRIBUTOR),Ubuntu)
51DEFAULT_PATH := /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
52else
53DEFAULT_PATH := /usr/local/bin:/usr/bin:/bin:/usr/games
54endif
55SUPERUSER_PATH := /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
56
57ifeq ($(DISTRIBUTOR),Ubuntu)
58server_recommends := ssh-import-id
59else
60server_recommends :=
61endif
62
63# Common path configuration.
64confflags += --sysconfdir=/etc/ssh
65confflags += --libexecdir=\$${prefix}/lib/openssh
66
67# Common build options.
68confflags += --disable-strip
69confflags += --with-mantype=doc
70confflags += --with-4in6
71confflags += --with-privsep-path=/run/sshd
72confflags += --with-pid-dir=/run
73
74# The Hurd needs libcrypt for res_query et al.
75ifeq ($(DEB_HOST_ARCH_OS),hurd)
76confflags += --with-libs=-lcrypt
77endif
78
79# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=60155
80ifeq ($(DEB_HOST_ARCH),hppa)
81confflags += --without-hardening
82endif
83
84# Everything above here is common to the deb and udeb builds.
85confflags_udeb := $(confflags)
86
87# Options specific to the deb build.
88confflags += --with-tcp-wrappers
89confflags += --with-pam
90confflags += --with-libedit
91confflags += --with-kerberos5=/usr
92confflags += --with-ssl-engine
93ifeq ($(DEB_HOST_ARCH_OS),linux)
94confflags += --with-selinux
95confflags += --with-audit=linux
96confflags += --with-systemd
97endif
98
99# The deb build wants xauth; the udeb build doesn't.
100confflags += --with-xauth=/usr/bin/xauth
101confflags_udeb += --without-xauth
102
103# Default paths. The udeb build has /usr/games removed.
104confflags += --with-default-path=$(DEFAULT_PATH) --with-superuser-path=$(SUPERUSER_PATH)
105confflags_udeb += --with-default-path=/usr/local/bin:/usr/bin:/bin --with-superuser-path=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
106
107# Compiler flags.
108export DEB_BUILD_MAINT_OPTIONS := hardening=+all
109include /usr/share/dpkg/buildflags.mk
110cflags := $(CPPFLAGS) $(CFLAGS)
111cflags += -DSSH_EXTRAVERSION=\"$(SSH_EXTRAVERSION)\"
112cflags_udeb := -Os
113cflags_udeb += -DSSH_EXTRAVERSION=\"$(SSH_EXTRAVERSION)\"
114confflags += --with-cflags='$(cflags)'
115confflags_udeb += --with-cflags='$(cflags_udeb)'
116
117# Linker flags.
118confflags += --with-ldflags='$(strip -Wl,--as-needed $(LDFLAGS))'
119confflags_udeb += --with-ldflags='-Wl,--as-needed'
120
121%:
122 dh $@ --with=autoreconf,systemd
123
124autoreconf:
125 autoreconf -f -i
126 cp -f /usr/share/misc/config.guess /usr/share/misc/config.sub ./
127
128override_dh_autoreconf-arch:
129 dh_autoreconf debian/rules -- autoreconf
130
131override_dh_autoreconf-indep:
132
133override_dh_auto_configure-arch:
134 dh_auto_configure -Bdebian/build-deb -- $(confflags)
135 dh_auto_configure -Bdebian/build-udeb -- $(confflags_udeb)
136
137override_dh_auto_configure-indep:
138
139override_dh_auto_build-arch:
140 # Avoid libnsl linkage. Ugh.
141 perl -pi -e 's/ +-lnsl//' debian/build-udeb/config.status
142 cd debian/build-udeb && ./config.status
143
144 $(MAKE) -C debian/build-deb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass'
145 $(MAKE) -C debian/build-udeb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass' ssh scp sftp sshd ssh-keygen
146
147 $(MAKE) -C contrib gnome-ssh-askpass3 CC='$(CC) $(CPPFLAGS) $(CFLAGS) -Wall -Wl,--as-needed $(LDFLAGS)' PKG_CONFIG=$(PKG_CONFIG)
148
149override_dh_auto_build-indep:
150
151override_dh_auto_test-arch:
152ifeq ($(RUN_TESTS),yes)
153 $(MAKE) -C debian/build-deb regress-prep
154 $(MAKE) -C debian/build-deb $(PARALLEL) regress-binaries
155 $(MAKE) -C debian/build-deb/regress \
156 .OBJDIR="$(CURDIR)/debian/build-deb/regress" \
157 .CURDIR="$(CURDIR)/regress" \
158 unit
159 $(MAKE) -C debian/build-deb compat-tests
160 $(MAKE) -C debian/keygen-test
161endif
162
163override_dh_auto_test-indep:
164
165override_dh_auto_clean:
166 rm -rf debian/build-deb debian/build-udeb
167ifeq ($(RUN_TESTS),yes)
168 $(MAKE) -C debian/keygen-test clean
169endif
170 $(MAKE) -C contrib clean
171
172override_dh_auto_install-arch:
173 $(MAKE) -C debian/build-deb DESTDIR=`pwd`/debian/tmp install-nokeys
174
175override_dh_auto_install-indep:
176
177override_dh_install-arch:
178 rm -f debian/tmp/etc/ssh/sshd_config
179
180 dh_install -Nopenssh-client-udeb -Nopenssh-server-udeb --fail-missing
181 dh_install -popenssh-client-udeb -popenssh-server-udeb \
182 --sourcedir=debian/build-udeb
183
184 # Remove version control tags to avoid unnecessary conffile
185 # resolution steps for administrators.
186 sed -i '/\$$OpenBSD:/d' \
187 debian/openssh-client/etc/ssh/moduli \
188 debian/openssh-client/etc/ssh/ssh_config
189
190# We'd like to use dh_install --fail-missing here, but that doesn't work
191# well in combination with dh-exec: it complains that files generated by
192# dh-exec for architecture-dependent packages aren't installed.
193override_dh_install-indep:
194 rm -f debian/tmp/etc/ssh/sshd_config
195 dh_install
196
197override_dh_installdocs:
198 dh_installdocs -Nopenssh-server -Nopenssh-sftp-server
199 dh_installdocs -popenssh-server -popenssh-sftp-server \
200 --link-doc=openssh-client
201 # Avoid breaking dh_installexamples later.
202 mkdir -p debian/openssh-server/usr/share/doc/openssh-client
203
204override_dh_systemd_enable:
205 dh_systemd_enable -popenssh-server --name ssh ssh.service
206 dh_systemd_enable -popenssh-server --name ssh --no-enable ssh.socket
207
208override_dh_installinit:
209 dh_installinit -R --name ssh
210
211debian/openssh-server.sshd.pam: debian/openssh-server.sshd.pam.in
212ifeq ($(DEB_HOST_ARCH_OS),linux)
213 sed 's/^@IF_KEYINIT@//' $< > $@
214else
215 sed '/^@IF_KEYINIT@/d' $< > $@
216endif
217
218override_dh_installpam: debian/openssh-server.sshd.pam
219 dh_installpam --name sshd
220
221override_dh_fixperms-arch:
222 dh_fixperms
223 chmod u+s debian/openssh-client/usr/lib/openssh/ssh-keysign
224
225# Tighten libssl dependencies to match the check in entropy.c.
226override_dh_shlibdeps:
227 dh_shlibdeps
228 debian/adjust-openssl-dependencies
229
230override_dh_gencontrol:
231 dh_gencontrol -- -V'openssh-server:Recommends=$(server_recommends)'
232
233override_dh_builddeb:
234 dh_builddeb -- -Zxz
235
236debian/faq.html:
237 wget -O - http://www.openssh.com/faq.html | \
238 sed 's,\(href="\)\(txt/\|[^":]*\.html\),\1http://www.openssh.com/\2,g' \
239 > debian/faq.html