summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 9eebacfb2..fad195dac 100755
--- a/debian/rules
+++ b/debian/rules
@@ -77,6 +77,8 @@ ifeq ($(DEB_HOST_ARCH_OS),linux)
77 # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999). 77 # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999).
78 perl -pi -e 's/.*#undef (BROKEN_SETRES[UG]ID).*/#define $$1 1/' build-deb/config.h 78 perl -pi -e 's/.*#undef (BROKEN_SETRES[UG]ID).*/#define $$1 1/' build-deb/config.h
79endif 79endif
80 # Debian's /var/log/btmp has inappropriate permissions.
81 perl -pi -e 's,.*#define USE_BTMP .*,/* #undef USE_BTMP */,' build-deb/config.h
80 82
81 $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""' 83 $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""'
82 # Support building on Debian 3.0 (with GNOME 1.4) and later. 84 # Support building on Debian 3.0 (with GNOME 1.4) and later.
@@ -93,6 +95,8 @@ build-udeb-stamp:
93 dh_testdir 95 dh_testdir
94 mkdir -p build-udeb 96 mkdir -p build-udeb
95 cd build-udeb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib/openssh --without-xauth --with-default-path=/usr/local/bin:/bin:/usr/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper 97 cd build-udeb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib/openssh --without-xauth --with-default-path=/usr/local/bin:/bin:/usr/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper
98 # Debian's /var/log/btmp has inappropriate permissions.
99 perl -pi -e 's,.*#define USE_BTMP .*,/* #undef USE_BTMP */,' build-deb/config.h
96 # Avoid libnsl linkage. Ugh. 100 # Avoid libnsl linkage. Ugh.
97 perl -pi -e 's/ +-lnsl//' build-udeb/config.status 101 perl -pi -e 's/ +-lnsl//' build-udeb/config.status
98 cd build-udeb && ./config.status 102 cd build-udeb && ./config.status